Bug 128005 - problem with g++
problem with g++
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 07:05 EDT by diego
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 16:41:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description diego 2004-07-16 07:05:53 EDT
Description of problem:problem of compiling wesnoth-0.8

I have downloaded a new version of game "wesnoth", relise 0.8, and in
the compiling i have this result:

root @ /usr/src/wesnoth-0.8 # make
make  all-recursive
make[1]: Entering directory `/usr/src/wesnoth-0.8'
Making all in src
make[2]: Entering directory `/usr/src/wesnoth-0.8/src'
Making all in .
make[3]: Entering directory `/usr/src/wesnoth-0.8/src'
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL - D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11  -I/usr/X1
1R6/include -fno-omit-frame-pointer -MT actions.o -MD -MP -MF
".deps/actions.Tpo " \
  -c -o actions.o `test -f 'actions.cpp' || echo './'`actions.cpp; \
then mv -f ".deps/actions.Tpo" ".deps/actions.Po"; \
else rm -f ".deps/actions.Tpo"; exit 1; \
fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11 
-I/usr/X11R6/include -fno-omit-frame-pointer -MT ai.o -MD -MP -MF
".deps/ai.Tpo" \
  -c -o ai.o `test -f 'ai.cpp' || echo './'`ai.cpp; \
then mv -f ".deps/ai.Tpo" ".deps/ai.Po"; \
else rm -f ".deps/ai.Tpo"; exit 1; \
fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11 
-I/usr/X11R6/include -fno-omit-frame-pointer -MT ai_attack.o -MD -MP
-MF ".deps/ai_attack.Tpo" \
  -c -o ai_attack.o `test -f 'ai_attack.cpp' || echo './'`ai_attack.cpp; \
then mv -f ".deps/ai_attack.Tpo" ".deps/ai_attack.Po"; \
else rm -f ".deps/ai_attack.Tpo"; exit 1; \
fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11 
-I/usr/X11R6/include -fno-omit-frame-pointer -MT ai_move.o -MD -MP -MF
".deps/ai_move.Tpo" \
  -c -o ai_move.o `test -f 'ai_move.cpp' || echo './'`ai_move.cpp; \
then mv -f ".deps/ai_move.Tpo" ".deps/ai_move.Po"; \
else rm -f ".deps/ai_move.Tpo"; exit 1; \
fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11 
-I/usr/X11R6/include -fno-omit-frame-pointer -MT dialogs.o -MD -MP -MF
".deps/dialogs.Tpo" \
  -c -o dialogs.o `test -f 'dialogs.cpp' || echo './'`dialogs.cpp; \
then mv -f ".deps/dialogs.Tpo" ".deps/dialogs.Po"; \
else rm -f ".deps/dialogs.Tpo"; exit 1; \
fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/X11R6/include 
-I/usr/include/SDL -D_REENTRANT
-DWESNOTH_PATH=\"/usr/local/share/wesnoth\" -g -O2 -D_X11 
-I/usr/X11R6/include -fno-omit-frame-pointer -MT game.o -MD -MP -MF
".deps/game.Tpo" \
  -c -o game.o `test -f 'game.cpp' || echo './'`game.cpp; \
then mv -f ".deps/game.Tpo" ".deps/game.Po"; \
else rm -f ".deps/game.Tpo"; exit 1; \
fi
g++: Internal error: Terminated (program cc1plus)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[3]: *** [game.o] Error 1
make[3]: Leaving directory `/usr/src/wesnoth-0.8/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/wesnoth-0.8/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/wesnoth-0.8'
make: *** [all] Error 2
root @ /usr/src/wesnoth-0.8 #

Tanks for you works.

Diego (Italy).
Comment 1 Jakub Jelinek 2004-07-19 10:20:19 EDT
Terminated means that you, some other program on your system or the
kernel kill(1)ed the compiler.
That is generally not a GCC bug, unless it is because GCC eats
unreasonable amount of memory and gets killed by the kernel OOM killer.
So, please try to reproduce it and if you get the same problem,
see if it consumed more than say 500MB of memory.
Comment 2 Jakub Jelinek 2004-10-03 16:41:28 EDT
No feedback. Closing.

Note You need to log in before you can comment on or make changes to this bug.