Bug 1280053 - [RFE] Openstack Cloud provider images list do not show image attributes
[RFE] Openstack Cloud provider images list do not show image attributes
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ronnie Rasouli
openstack
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 15:41 EST by Marius Cornea
Modified: 2016-06-29 11:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:05:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
images (72.35 KB, image/png)
2015-11-10 15:41 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-11-10 15:41:24 EST
Created attachment 1092429 [details]
images

Description of problem:
The Openstack cloud provider images only show the Provider and Region attributes. 

Version-Release number of selected component (if applicable):
5.5.0.9-beta2.20151102161742_5530c9a

How reproducible:
100%

Steps to Reproduce:
1. Go to Cloud - Providers
2. Select the Openstack provider
3. Click on Relationships - Images

Actual results:
The images show attributes only in Provider and Region columns. 

Expected results:
All the discovered attributes show up. 

Additional info:
Attaching screenshot. 

I also tried running SmartState analysis for the images but nothing changed.
Comment 3 CFME Bot 2015-12-09 11:25:23 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/4c7ce57685888dd1c24c3aed520709cad83c9ba4

commit 4c7ce57685888dd1c24c3aed520709cad83c9ba4
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Nov 19 09:44:31 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Thu Nov 19 17:04:54 2015 +0100

    OpenStack get more info about images
    
    Getting more info about images from Glance. Cleaning up textual
    page hiding info we can't get.
    
    Also adding support fo Glance V2
    
    Implements BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1280053

 app/helpers/vm_cloud_helper/textual_summary.rb     | 32 +++++++++++++++---
 app/helpers/vm_helper/textual_summary.rb           |  1 +
 .../providers/openstack/cloud_manager/template.rb  |  4 +++
 .../openstack/refresh_parser_common/images.rb      | 39 +++++++++++++++++++---
 .../openstack/cloud_manager/refresh_spec_common.rb |  5 ++-
 .../infra_manager/refresher_rhos_juno_spec.rb      |  2 +-
 6 files changed, 69 insertions(+), 14 deletions(-)
Comment 4 Ronnie Rasouli 2016-05-30 10:54:55 EDT
Properties
Name 	private_rhel64
Container 	openstack: 0 CPUs, MB
Platform Tools 	N/A
Operating System 	Unknown
Architecture 	
Advanced Settings 	0
Management Engine GUID 	ea94af9e-2642-11e6-98bb-525400fc1418
Virtualization Type 	
wrong attributes. 
missing bare in container information
id is incorrect

glance image-show private_rhel64
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | 79b4436412283bb63c2cba4ac796bcd9     |
| container_format | bare                                 |
| created_at       | 2016-05-26T10:36:25.000000           |
| deleted          | False                                |
| disk_format      | qcow2                                |
| id               | c3f29e5a-effc-4f7c-ba96-f37d19e5b330 |
| is_public        | False                                |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | private_rhel64                       |
| owner            | fa1071996d8449ef8f6e62afb579c257     |
| protected        | False                                |
| size             | 12506112                             |
| status           | active                               |
| updated_at       | 2016-05-26T10:36:26.000000           |
+------------------+--------------------------------------+

Properties
Name 	private_rhel64
Container 	openstack: 0 CPUs, MB
Platform Tools 	N/A
Operating System 	Unknown
Architecture 	
Advanced Settings 	0
Management Engine GUID 	ea94af9e-2642-11e6-98bb-525400fc1418
Virtualization Type 	
Root Device Type 	qcow2 

Root Device Type 	qcow2
Lifecycle
Discovered 	Mon May 30 08:45:52 UTC 2016
Last Analyzed 	Mon May 30 13:51:33 UTC 2016
Group 	Tenant My Company access
Relationships
Cloud Provider 	rhos8_overcloud
Parent VM 	None
Drift History 	1
Analysis History 	1
Cloud Tenants 	admin
Compliance
Status 	Never Verified
History 	Not Available
Power Management
Power State 	never
Security
Users 	16
Groups 	19
Configuration
Packages 	0
Init Processes 	0
Files 	0
Smart Management
My Company Tags 	No My Company Tags have been assigned

Compliance
Status 	Never Verified
History 	Not Available
Power Management
Power State 	never
Security
Users 	16
Groups 	19
Configuration
Packages 	0
Init Processes 	0
Files 	0
Smart Management
My Company Tags 	No My Company Tags have been assigned
Comment 7 Ronnie Rasouli 2016-05-31 04:11:31 EDT
The image size and other details shown
Comment 9 errata-xmlrpc 2016-06-29 11:05:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.