This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1280090 - python3-pocketlint should use the just built version to run "make check"
python3-pocketlint should use the just built version to run "make check"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python3-pocketlint (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 17:36 EST by Peter Robinson
Modified: 2015-11-10 19:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 19:07:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2015-11-10 17:36:15 EST
So python3-pocketlint depends on it's self from a rpm dependency to run "make check" and if it doesn't have the dependency it fails as below BUT it should be using the just built version to be running the "make check" not the previous version because if it uses the previous version it doesn't actually verify that the new, just built, version is actually working. 


Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.GKaem3
+ umask 022
+ cd /builddir/build/BUILD
+ cd pocketlint-0.9
+ make check
*** Running pylint to verify source ***
PYTHONPATH=./build/lib tests/pylint/runpylint.py
Traceback (most recent call last):
  File "tests/pylint/runpylint.py", line 19, in <module>
    rc = linter.run()
  File "/builddir/build/BUILD/pocketlint-0.9/build/lib/pocketlint/__init__.py", line 303, in run
    result = job.result()
  File "/usr/lib64/python3.5/concurrent/futures/_base.py", line 398, in result
    return self.__get_result()
  File "/usr/lib64/python3.5/concurrent/futures/_base.py", line 357, in __get_result
    raise self._exception
  File "/usr/lib64/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/builddir/build/BUILD/pocketlint-0.9/build/lib/pocketlint/__init__.py", line 267, in _run_one
    stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib64/python3.5/subprocess.py", line 950, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.5/subprocess.py", line 1540, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: 'python3-pylint'
Makefile:12: recipe for target 'check' failed
Comment 1 Peter Robinson 2015-11-10 19:07:31 EST
bah, confusing pocketlint and pylint. Clearly been looking too closely at too many packages today

Note You need to log in before you can comment on or make changes to this bug.