Bug 128011 - Error "crypto_hmac_update undeclared " in make bzImage operation
Error "crypto_hmac_update undeclared " in make bzImage operation
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ernie Petrides
Depends On:
  Show dependency treegraph
Reported: 2004-07-16 08:22 EDT by D-COSNEAU
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-03 20:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description D-COSNEAU 2004-07-16 08:22:13 EDT
Description of problem:
with no kernel option change, i can't make bzImage on the original
and standard kernel sources (Linux version 2.4.21-9.ELsmp 
(bhcompile@stripples.devel.redhat.com) (gcc version 3.2.3 20030502 
(Red Hat Linux 3.2.3-26)) #1 SMP Thu Jan 8 17:08:56 EST 2004).
The result reports a problem with crypto_hmac_update undeclared.

sorry for my bad english!

Version-Release number of selected component (if applicable):

How reproducible: 
standard procedure for kernel compil at point : make bzImage

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 D-COSNEAU 2004-07-16 08:23:51 EDT
part of the make bzImage report :

/usr/src/linux-2.4.21-9.EL/include/net/ah.h:28: warning: implicit 
declaration of function `crypto_hmac_final'
In file included from xfrm_algo.c:19:
/usr/src/linux-2.4.21-9.EL/include/net/esp.h: In function 
/usr/src/linux-2.4.21-9.EL/include/net/esp.h:49: `crypto_hmac_update' 
undeclared (first use in this function)
make[3]: *** [xfrm_algo.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.21-9.EL/net/xfrm'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.21-9.EL/net/xfrm'
make[1]: *** [_subdir_xfrm] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.21-9.EL/net'
make: *** [_dir_net] Error 2
Comment 2 Pierre Fumery 2004-07-27 06:59:46 EDT
It seems there was another bug about this problem (109636) but no
final solution has been found. Is this a mis-understanding (= there is
a solution) or is there still a problem ?
Comment 3 John T. Rose 2004-11-12 16:32:35 EST
I ran into this bug I think today when trying to compile a new kernel.
 I began using kernel-2.4.21-athlon.config and discovered that if I
did "make oldconfig" or "make menuconfig" all worked fine but using
"make xconfig" the above error occurred.  IIRC the person who reported
109636 also used xconfig so perhaps the problem lies in that direction?!
Comment 4 Ernie Petrides 2005-06-03 20:10:19 EDT
Hello, Dominique.

The correct build-from-source procedure is as follows:

  1) make mrproper
  2) cp configs/kernel-2.4.21-i686-smp.config .config  [or some other config]
  3) make oldconfig
  4) make dep
  5) make bzImage
  6) make modules

Cheers.  -ernie

Note You need to log in before you can comment on or make changes to this bug.