Bug 128012 - IPF OS_INIT handler does not print any information
IPF OS_INIT handler does not print any information
Status: CLOSED DUPLICATE of bug 130800
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anil S Keshavamurthy
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 08:28 EDT by Jun'ichi NOMURA
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 16:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun'ichi NOMURA 2004-07-16 08:28:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6)
Gecko/20040528 Debian/1.6-7

Description of problem:
   IPF OS_INIT handler (which is implemented in arch/ia64/kernel/mca.c)
   is called when INIT interrupt is issued.

   The handler in RHEL3 prints the processor's register information
   to the console.

   It works on 2.4.21-15.EL, but it does not work on 2.4.21-17.EL.
   I also tried 2.6.7 and it works.


Version-Release number of selected component (if applicable):
kernel-2.4.21-17.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot up OS
2. Issue INIT interrupt
3.
    

Actual Results:  Nothing displayed on console

Expected Results:  The message "Entered OS INIT handler." appears on
console,
then register information and some other information will follow.


Additional info:

I tried 'dmesg -n 8' to display all messages to console,
but it doesn't work either.

With 2.4.21-15.EL kernel, the expected messages appear on console.
Comment 1 Anil S Keshavamurthy 2006-05-08 19:42:29 EDT
Do you still see this bug in the latest RHEL3 update kernel?
Comment 2 Jun'ichi NOMURA 2006-05-09 08:24:22 EDT
I don't have an access to the machine currently
and cannot answer promptly. I'll check if I can
find a way to test.

Is it just a confirmation?

Or are there any related fix in the recent kernel
which might affect this bug?
If so, should I try any specific version?

Comment 3 Anil S Keshavamurthy 2006-05-09 13:12:14 EDT
I just started to look at this bug and will be helpful if you can see if the
problem still exist on the latest RHEL3 U8 kernel.
Comment 4 Jun'ichi NOMURA 2006-05-09 15:30:43 EDT
OK, thanks for looking.

I tried 2.4.21-42.EL on currently available machine
and saw no problem.

Please close this bug.

Comment 5 Ernie Petrides 2006-05-09 16:40:11 EDT
This problem was fixed in RHEL3 U4.

*** This bug has been marked as a duplicate of 130800 ***

Note You need to log in before you can comment on or make changes to this bug.