Bug 1280171 - Fail to install env on Atomic when 'openshift_set_hostname' is true
Fail to install env on Atomic when 'openshift_set_hostname' is true
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 00:22 EST by Ma xiaoqiang
Modified: 2016-07-03 20:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:42:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0075 normal SHIPPED_LIVE Red Hat OpenShift Enterprise atomic-openshift-utils bug fix update 2016-01-27 19:42:22 EST

  None (edit)
Description Ma xiaoqiang 2015-11-11 00:22:59 EST
Description of problem:
Should set hostname of atomic in playbook

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible/tree/containers

How reproducible:
Always


Steps to Reproduce:

1. Install env on atomic without setting hostname of atomic



Actual results:
Can not start master service

Nov 11 12:59:11 atomic.nay.redhat.com docker[4477]: E1110 23:59:11.528140       1 common.go:722] Failed to lookup IP address for node atomic.nay.redhat.co...such host
Nov 11 12:59:11 atomic.nay.redhat.com docker[4477]: F1110 23:59:11.528178       1 flatsdn.go:27] SDN initialization failed: lookup atomic.nay.redhat.com: no such host


Expected results:
Start the master service successfully

Additional info:
The playbook will configure hostname of rhel. we also can configure the hostname of atomic via shell or command.
Comment 1 Jason DeTiberus 2015-11-18 15:10:18 EST
I've submitted https://github.com/openshift/openshift-ansible/pull/924 to remove setting the hostname.

Since the hostname workaround is no longer needed, we should pull this into the containerization work as well.
Comment 2 Scott Dodson 2015-11-23 11:36:20 EST
The setting of hostname has been removed from ansible. I'd say that the SDN requires the nodename be resolvable at this point in time. This isn't a containerization specific issue.
Comment 3 Ma xiaoqiang 2015-11-24 02:30:51 EST
If we do not set hostname. we can not start the master service. The setting of hostname has been removed from ansible, so the master still can not be restarted.

Even if the ansible set the hostname, the module 'hostname' in ansible still doesn't support atomic platform.
Comment 4 Scott Dodson 2016-01-11 12:56:48 EST
I need to check with Jason on the latest for when we need to set the hostname. I don't think that we need this functionality in the majority of cases.
Comment 5 Scott Dodson 2016-01-11 16:32:39 EST
After discussing this with Jason there are still major problems associated with setting a hostname that doesn't resolve and those won't be fixed until kube 1.2 or later. However if you want to set the hostname of a host to a valid hostname we should allow you to do that.

Here's my proposed fix https://github.com/openshift/openshift-ansible/pull/1165
Comment 8 errata-xmlrpc 2016-01-27 14:42:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.