Bug 1280210 - deadlock in mep delete post op
deadlock in mep delete post op
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
Depends On: 1273555
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 03:36 EST by Jan Kurik
Modified: 2015-12-08 05:34 EST (History)
8 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.4.0-20.el7_2
Doc Type: Bug Fix
Doc Text:
In the back end deletion, a transaction info was not passed to one of the database helper functions. Consequently, if a plug-in attempted to access data in the area locked by the transaction, a deadlock situation could occur. Now, the transaction info is passed to all the necessary database helper functions, and a deadlock no longer occurs in the described situation.
Story Points: ---
Clone Of: 1273555
Environment:
Last Closed: 2015-12-08 05:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-11 03:36:09 EST
This bug has been copied from bug #1273555 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 Amita Sharma 2015-11-24 05:43:44 EST
[root@dhcp201-167 dirsrvtests]# rpm -qa | grep 389
389-ds-base-1.3.4.0-21.el7_2.x86_64
389-ds-base-libs-1.3.4.0-21.el7_2.x86_64
389-ds-base-debuginfo-1.3.4.0-21.el7_2.x86_64


sudo py.test -v -s --debug  ticket47976_test.py
INFO:lib389:dir (sys) : //etc/sysconfig
INFO:lib389:dir (priv): /root/.dirsrv
/root/.dirsrv/dirsrv-*
//etc/sysconfig/dirsrv-*
INFO:lib389:List from /root/.dirsrv
INFO:lib389:list instance {'RUN_DIR': '/var/run/dirsrv', 'SERVER_ID': 'standalone', 'hostname': 'localhost.localdomain', 'ldap-port': 31389, 'ldap-secureport': None, 'DS_ROOT': '', 'deployed-dir': '/', 'INST_DIR': '/usr/lib64/dirsrv/slapd-standalone', 'SERVER_DIR': '/usr/lib64/dirsrv', 'server-id': 'standalone', 'SERVERBIN_DIR': '/usr/sbin', 'root-dn': 'cn=Directory Manager', 'user-id': 'dirsrv', 'CONFIG_DIR': '/etc/dirsrv/slapd-standalone', 'PRODUCT_NAME': 'slapd', 'suffix': 'dc=example,dc=com'}

DEBUG:lib389:running: /usr/sbin/remove-ds.pl -i slapd-standalone 
Instance slapd-standalone removed.


============================================================= 4 passed in 48.99 seconds ==============================================================
wrote pytestdebug information to /export/ds/dirsrvtests/tickets/pytestdebug.log
Comment 7 errata-xmlrpc 2015-12-08 05:34:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2572.html

Note You need to log in before you can comment on or make changes to this bug.