Bug 1280237 - Should quit to "Hosted Engine" page when encounter error during HE setup
Summary: Should quit to "Hosted Engine" page when encounter error during HE setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-3.6.1
: 3.6.0
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-11 10:04 UTC by wanghui
Modified: 2016-03-09 14:43 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:43:16 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 47670 master MERGED Close the deploy dialog forcefully to avoid a race Never
oVirt gerrit 48978 ovirt-3.6 MERGED Close the deploy dialog forcefully to avoid a race Never

Description wanghui 2015-11-11 10:04:47 UTC
Description of problem:
It should quit to "Hosted Engine" page instead of "Begin Hosted Engine Setup" page when encounter error.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151104.0.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch 
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Start Hosted Engine deploy
4. Answer "Are you sure you want to continue?(Yes, No)[Yes]: No
5. Press any key

Actual results:
1. After step5, it quit to "Begin Hosted Engine Setup" page. 

Expected results:
1.After step5, it should quit to "Hosted Engine" page. 

Additional info:

Comment 2 wanghui 2015-12-04 07:38:43 UTC
Test Version:
rhev-hypervisor7-7.2-20151201.2.el7ev
ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev.noarch

Test steps:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Start Hosted Engine deploy
4. Answer "Are you sure you want to continue?(Yes, No)[Yes]: No
5. Press any key

Test result:
1. After step5, it quit to "Hosted Engine" page. 

So this issue is fixed in ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev.noarch. Change the status to verified.

Comment 4 errata-xmlrpc 2016-03-09 14:43:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.