Bug 1280242 - 1.70 does not seem to report any warning
1.70 does not seem to report any warning
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cppcheck (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
http://trac.cppcheck.net/ticket/7128
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:16 EST by Mamoru TASAKA
Modified: 2015-12-08 16:23 EST (History)
2 users (show)

See Also:
Fixed In Version: cppcheck-1.70-4.el7 cppcheck-1.70-4.fc23 cppcheck-1.70-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 01:26:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The result of nm -D for cppcheck (1.70-1) (319.17 KB, text/plain)
2015-11-13 02:50 EST, Mamoru TASAKA
no flags Details
The result of nm -D for cppcheck (1.70-3) (224.85 KB, text/plain)
2015-11-13 02:52 EST, Mamoru TASAKA
no flags Details
Patch for force linking the whole archive (934 bytes, patch)
2015-11-13 02:54 EST, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2015-11-11 05:16:21 EST
Description of problem:
With cppcheck 1.70, it seems that no warning is raised?? (at least with 1.70-2)


Version-Release number of selected component (if applicable):
cppcheck-1.70-2.fc2X.x86_64

How reproducible:
100% (at least tried on F-24 and F-22)


Steps to Reproduce:
1. fedpkg co --branches xscreensaver
2. cd xscreensaver/master
3. fedpkg sources
4. tar xf xscreensaver-5.34.tar.gz
5. cd xscreensaver-5.34
6. cppcheck --force --enable-all driver/splash.c

Actual results:
With cppcheck-1.70-2

Checking driver/splash.c...
Checking driver/splash.c: HAVE_CONFIG_H...
Checking driver/splash.c: HAVE_MIT_SAVER_EXTENSION...
Checking driver/splash.c: HAVE_PROC_INTERRUPTS...
Checking driver/splash.c: HAVE_RANDR...
Checking driver/splash.c: HAVE_SGI_SAVER_EXTENSION...
Checking driver/splash.c: HAVE_SIGACTION...
Checking driver/splash.c: HAVE_UNISTD_H...
Checking driver/splash.c: HAVE_XF86VMODE...
Checking driver/splash.c: HAVE_XINPUT...
Checking driver/splash.c: NO_LOCKING...
Checking driver/splash.c: PREFS_BUTTON...
Checking driver/splash.c: QUAD_MODE...
Checking driver/splash.c: VMS...
(information) Cppcheck cannot find all the include files (use --check-config for details)


Expected results:
With cppcheck-1.68-1
Checking driver/splash.c...
[driver/splash.c:427]: (style) The scope of the variable 'mouse_x' can be reduced.
[driver/splash.c:427]: (style) The scope of the variable 'mouse_y' can be reduced.
[driver/splash.c:438]: (style) Variable 'mouse_x' is assigned a value that is never used.
[driver/splash.c:439]: (style) Variable 'mouse_y' is assigned a value that is never used.
[driver/splash.c:583]: (style) Variable 'hspacing' is assigned a value that is never used.
Checking driver/splash.c: HAVE_CONFIG_H...
Checking driver/splash.c: HAVE_MIT_SAVER_EXTENSION...
Checking driver/splash.c: HAVE_PROC_INTERRUPTS...
Checking driver/splash.c: HAVE_RANDR...
Checking driver/splash.c: HAVE_SGI_SAVER_EXTENSION...
Checking driver/splash.c: HAVE_SIGACTION...
Checking driver/splash.c: HAVE_UNISTD_H...
Checking driver/splash.c: HAVE_XF86VMODE...
Checking driver/splash.c: HAVE_XINPUT...
Checking driver/splash.c: NO_LOCKING...
Checking driver/splash.c: PREFS_BUTTON...
Checking driver/splash.c: QUAD_MODE...
Checking driver/splash.c: VMS...
[driver/splash.c:778]: (style) The function 'handle_splash_event' is never used.
[driver/splash.c:159]: (style) The function 'make_splash_dialog' is never used.
(information) Cppcheck cannot find all the include files (use --check-config for details)


Additional info:
Comment 1 Susi Lehtola 2015-11-11 23:21:41 EST
Looks like the switch to CMake needed to get the GUI compiled broke this. cppcheck-1.70-1 works, but cppcheck-1.70-2 doesn't. It also isn't a question of pcre features getting dropped in -2, which I re-enabled in -3.

Maybe upstream can shed some light on this
http://trac.cppcheck.net/ticket/7128
Comment 2 Mamoru TASAKA 2015-11-13 02:50 EST
Created attachment 1093563 [details]
The result of nm -D for cppcheck (1.70-1)

The result of
$ nm -D --demangle /usr/bin/cppcheck for 1.70-1
Comment 3 Mamoru TASAKA 2015-11-13 02:52 EST
Created attachment 1093565 [details]
The result of nm -D for cppcheck (1.70-3)

Also for 1.70-3

So many symbols are missing on -3 compared to 1.70-1.
Comment 4 Mamoru TASAKA 2015-11-13 02:54 EST
Created attachment 1093567 [details]
Patch for force linking the whole archive

Looks like the attached patch seems to work. Would you check this?
Comment 5 Mamoru TASAKA 2015-11-13 05:31:40 EST
(Note that my patch does not apply to the original source, because
 libtinyxml2 linkage option changed beforehand)
Comment 6 Susi Lehtola 2015-11-13 12:27:09 EST
(In reply to Mamoru TASAKA from comment #4)
> Created attachment 1093567 [details]
> Patch for force linking the whole archive
> 
> Looks like the attached patch seems to work. Would you check this?

Looks like it does, thanks Mamoru!
Comment 7 Fedora Update System 2015-11-13 18:40:28 EST
cppcheck-1.70-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b8a1961427
Comment 8 Fedora Update System 2015-11-13 18:40:30 EST
cppcheck-1.70-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e29c31c79c
Comment 9 Fedora Update System 2015-11-13 18:40:37 EST
cppcheck-1.70-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1ace14240b
Comment 10 Fedora Update System 2015-11-13 18:40:37 EST
cppcheck-1.70-4.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-46c848c523
Comment 11 Mamoru TASAKA 2015-11-13 23:59:35 EST
I wrote some comments on
http://trac.cppcheck.net/ticket/7128#comment:10
Comment 12 Fedora Update System 2015-11-14 16:51:48 EST
cppcheck-1.70-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update cppcheck'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-e29c31c79c
Comment 13 Fedora Update System 2015-11-14 23:20:05 EST
cppcheck-1.70-4.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cppcheck'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-46c848c523
Comment 14 Fedora Update System 2015-11-14 23:22:53 EST
cppcheck-1.70-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cppcheck'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1ace14240b
Comment 15 Fedora Update System 2015-11-15 00:25:54 EST
cppcheck-1.70-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cppcheck'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b8a1961427
Comment 16 Fedora Update System 2015-12-08 01:26:22 EST
cppcheck-1.70-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-12-08 14:54:07 EST
cppcheck-1.70-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-12-08 16:23:26 EST
cppcheck-1.70-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.