Bug 1280257 - Containers: Failed to create OpenShift Provider in ContainerManager
Containers: Failed to create OpenShift Provider in ContainerManager
Status: CLOSED DUPLICATE of bug 1278041
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.0
Assigned To: Gregg Tanzillo
Dave Johnson
container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:50 EST by Avi Tal
Modified: 2016-04-22 00:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Using openshift installed on OpenStack Installing CFME VM on OpenStack as well
Last Closed: 2015-11-11 06:12:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Tal 2015-11-11 05:50:07 EST
Description of problem:
Using REST API to add new OpenShift provider is failing due to missing userid/password credentials.

Version-Release number of selected component (if applicable):
CFME 4.0 beta2 5.5.0.9

How reproducible:
<cfme> == cfme ip
<token> == generated token on OpenShift master

use postman chrome extension
Add credentials to postman
or
login, on a different tab, to cfme ui


Steps to Reproduce:
POST https://<cfme>/api/providers

{
  "type"      : "ManageIQ::Providers::Openshift::ContainerManager",
  "name"      : "atal-oc",
  "hostname" : "10.8.48.66",
  "ipaddress" : "10.8.48.66",
  "credentials" : {
    "token" : "<token>"
  }
}


Actual results:
{
error: {
kind: "bad_request"
message: "Could not create the new provider - Unsupported credential attributes token specified, ManageIQ::Providers::Openshift::ContainerManager supports: userid, password"
klass: "ApiController::BadRequestError"
}-
}

Expected results:
{
  "results": [
    {
      "id": 105,
      "name": "atal-oc",
      "hostname": "10.8.48.66",
      "ipaddress": "10.8.48.66",
      "created_on": "2015-05-05T15:47:41Z",
      "updated_on": "2015-05-05T15:47:41Z",
      "guid": "10360312-f33e-11e4-86c7-b8e85646e742",
      "zone_id": 1,
      "type": "ManageIQ::Providers::Openshift::ContainerManager"
    }
  ]
}

Additional info:
Comment 2 Jaroslav Henner 2015-11-11 06:12:07 EST

*** This bug has been marked as a duplicate of bug 1278041 ***

Note You need to log in before you can comment on or make changes to this bug.