Bug 1280290 - virt-builder: unable to build f23 image: error: dnf -y update: command exited with an error
virt-builder: unable to build f23 image: error: dnf -y update: command exited...
Status: CLOSED DUPLICATE of bug 1280029
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 07:18 EST by Lukas Brabec
Modified: 2015-11-11 07:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 07:28:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-builder -v -x output (20.68 KB, text/plain)
2015-11-11 07:18 EST, Lukas Brabec
no flags Details

  None (edit)
Description Lukas Brabec 2015-11-11 07:18:08 EST
Description of problem:
I want to build F23 image using command:

$ virt-builder fedora-23 --output fedora-23.qcow2 --format qcow2 --update

I got a stacktrace:
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 173, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 220, in do_transaction
    self.gpgsigcheck(downloadpkgs)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 251, in gpgsigcheck
    if not sys.stdin.isatty() and not ay:
AttributeError: 'NoneType' object has no attribute 'isatty'

caused by 'dnf -y update' command.


Version-Release number of selected component (if applicable):
libguestfs-1.30.4-1.fc23.x86_64
libguestfs-tools-1.30.4-1.fc23.noarch
Comment 1 Lukas Brabec 2015-11-11 07:18 EST
Created attachment 1092665 [details]
virt-builder -v -x output
Comment 2 Pino Toscano 2015-11-11 07:28:32 EST
See also bug #1278382.

*** This bug has been marked as a duplicate of bug 1280029 ***

Note You need to log in before you can comment on or make changes to this bug.