Bug 1280331 - [Docs][Director] documentation on how to replace the following node roles: controller, block storage, object storage, ceph storage
[Docs][Director] documentation on how to replace the following node roles: co...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: RHOS Documentation Team
RHOS Documentation Team
: Documentation
Depends On: 1258068
Blocks: 1339506
  Show dependency treegraph
 
Reported: 2015-11-11 08:42 EST by Ondrej
Modified: 2017-05-11 23:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 13:32:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej 2015-11-11 08:42:42 EST
Description of problem:

The Red Hat OpenStack Director documentation currently misses documentation on how to replace the following node roles: controller, block storage, object storage, ceph storage. Currently, the only node role that is covered is Compute.

In order to operate an OpenStack cloud in production, there needs to be documentation on how to perform Overcloud node replacement. And this procedure should to be properly tested

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
description of replacing overcloud nodes

Additional info:
Comment 2 Felipe Alfaro Solana 2015-11-11 09:37:38 EST
Can we have these procedures documented for OSP-7? That's the release we are currently deploying, since there's no OSP-8 available at the moment.
Comment 3 Dan Macpherson 2015-11-11 22:14:10 EST
There's documentation in progress on replacing Controller nodes:

https://bugzilla.redhat.com/show_bug.cgi?id=1258068
Comment 4 Felipe Alfaro Solana 2016-05-23 05:00:13 EDT
What about replacing Ceph or Swift nodes? I don´t understand how an Enterprise product lacks this kind of such basic procedures.
Comment 5 Dan Macpherson 2016-05-23 05:56:43 EDT
Hi Felipe,

These procedures should be documented for OSPd 8:

Swift node replacement; https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/director-installation-and-usage/95-replacing-object-storage-nodes

Ceph node replacement: https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/red-hat-ceph-storage-for-the-overcloud/chapter-2-creating-an-overcloud-with-ceph-storage-nodes (See Section 2.12. Replacing Ceph Storage Nodes)

Was this the documentation you required?

Note You need to log in before you can comment on or make changes to this bug.