Bug 1280358 - Disk Alias and Description maximum size isn't restricted to max size
Disk Alias and Description maximum size isn't restricted to max size
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Idan Shaby
Natalie Gavrielov
:
: 1289855 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 09:39 EST by Eyal Shenitzky
Modified: 2016-07-05 03:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
engine log (63.72 KB, application/x-bzip)
2015-11-11 09:41 EST, Eyal Shenitzky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50691 master MERGED engine: limit disk alias and description length 2015-12-21 10:16 EST

  None (edit)
Description Eyal Shenitzky 2015-11-11 09:39:26 EST
Description of problem:

Disk alias maximum size is 255 characters, and description is 500 characters.
When entering long values into these fields,
For the alias, above 255 characters.
For the alias, above 500 characters.
Wrong Error massage received.
Verification of name size should be in the UI and not moved to the PostgreSQL.  

Version-Release number of selected component (if applicable):
3.6.0.3-0.1.el6

How reproducible:
Always

Steps to Reproduce:
1. Create disk with alias of 250-300 ascii characters,
   or description of more than 500 ascii characters.

Actual results:
Error massage recived -
Error while executing action Add Disk to VM: Internal Engine Error


Expected results:
Error massage should be - 
Error while executing action Add Disk to VM: alias or description is to long

Additional info:

Engine log attached
Comment 1 Eyal Shenitzky 2015-11-11 09:41 EST
Created attachment 1092783 [details]
engine log
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-11 10:10:40 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Idan Shaby 2015-12-10 01:38:22 EST
*** Bug 1289855 has been marked as a duplicate of this bug. ***
Comment 4 Natalie Gavrielov 2016-04-10 12:05:20 EDT
Verified,
ovirt-engine-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch

a. For more than 255 characters in the alias field the following message appears:
   Field content must not exceed 255 characters.

b. Fore more than 500 characters in the description field the following message 
   appears:
   Field content must not exceed 500 characters.

c. For 255 characters in the alias field - disk is created

d. For 500 characters in the description field - disk is created

e. For 255 characters in the alias field and 500 characters in the description 
   field - disk is created.
Comment 5 Sandro Bonazzola 2016-07-05 03:46:52 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.