Bug 1280371 - %post -erroronfail does require input even with inst.cmdline
%post -erroronfail does require input even with inst.cmdline
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:09 EST by Fabian Deutsch
Modified: 2016-11-03 19:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.57-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2015-11-11 10:09:27 EST
Description of problem:
When running anaconda in cmdline mode (appending inst.cmdline) and using a kickstart which includes a

%post --erroronfail
…
%end

snippet, then anaconda will prompt for input if the snippet fails.


Version-Release number of selected component (if applicable):
CentOS 7 version, quite sure in Fedora as well

How reproducible:
Always

Steps to Reproduce:
1. Failing postlet and anaconda with inst.cmdline
2.
3.

Actual results:
anaonda prompts for input

Expected results:
anaconda shows the error and shutsdown the host

Additional info:
Comment 1 David Shea 2015-11-12 10:49:12 EST
(In reply to Fabian Deutsch from comment #0)
> Version-Release number of selected component (if applicable):
> CentOS 7 version, quite sure in Fedora as well

This problem does not occur in Fedora.
Comment 3 Chris Lumens 2016-02-16 13:14:43 EST
This just needs a cherry pick of 8f361ad0539763f90a97f90443185f8726f2a553.
Comment 7 errata-xmlrpc 2016-11-03 19:19:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.