Bug 1280384 - FATAL Error: ActionController::RoutingError /components/font-awesome/fonts/fontawesome-webfont.ttf
FATAL Error: ActionController::RoutingError /components/font-awesome/fonts/f...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.6.0
Assigned To: Martin Hradil
Nandini Chandra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:36 EST by Thomas Hennessy
Modified: 2016-06-29 11:05 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:05:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-11-11 10:36:59 EST
Description of problem: problem seems to be associated with self-service UI


Version-Release number of selected component (if applicable):
5.5.0.9-beta2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: no error


Expected results: fatal error


Additional info:
full failing sequence from production log:
=====
[----] I, [2015-11-10T15:48:04.803074 #15008:56f98c]  INFO -- : Started GET "/components/font-awesome/fonts/fontawesome-webfont.woff2?v=4.3.0" for 127.0.0.1 at 2015-11-10 15:48:04 -0500
[----] F, [2015-11-10T15:48:04.804116 #15008:56f98c] FATAL -- : 
ActionController::RoutingError (No route matches [GET] "/components/font-awesome/fonts/fontawesome-webfont.woff2"):
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/rack/logger.rb:38:in `call_app'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/rack/logger.rb:22:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.4) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.4) lib/rack/runtime.rb:18:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activesupport/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
  rack (1.6.4) lib/rack/lock.rb:17:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/static.rb:116:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/static.rb:116:in `call'
  rack (1.6.4) lib/rack/sendfile.rb:113:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/engine.rb:518:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/application.rb:165:in `call'
  rack (1.6.4) lib/rack/content_length.rb:15:in `call'
  thin (1.6.3) lib/thin/connection.rb:86:in `block in pre_process'
  thin (1.6.3) lib/thin/connection.rb:84:in `catch'
  thin (1.6.3) lib/thin/connection.rb:84:in `pre_process'
  thin (1.6.3) lib/thin/connection.rb:53:in `process'
  thin (1.6.3) lib/thin/connection.rb:39:in `receive_data'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run_machine'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run'
  thin (1.6.3) lib/thin/backends/base.rb:73:in `start'
  thin (1.6.3) lib/thin/server.rb:162:in `start'
  rack (1.6.4) lib/rack/handler/thin.rb:19:in `run'
  rack (1.6.4) lib/rack/server.rb:286:in `start'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/server.rb:80:in `start'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:80:in `block in server'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:75:in `tap'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:75:in `server'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:4:in `require'
  bin/rails:4:in `<main>'
=====
Comment 4 Nandini Chandra 2016-04-26 00:00:23 EDT
Marking this as VERIFIED since font-awesome version 4.3.0  has been removed.
Comment 6 errata-xmlrpc 2016-06-29 11:05:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.