Bug 1280389 - [RFE] Provide The serial multiplexer for multiple users to get serial-console to the same guest-VM.
[RFE] Provide The serial multiplexer for multiple users to get serial-console...
Status: CLOSED WONTFIX
Product: ovirt-vmconsole
Classification: oVirt
Component: RFEs (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: Alon Bar-Lev
Nikolai Sednev
virt
:
Depends On: 1223671
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:55 EST by Nikolai Sednev
Modified: 2016-01-04 00:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 11:42:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Nikolai Sednev 2015-11-11 10:55:59 EST
Description of problem:
[RFE] Provide multiplexer for multiple users to get serial-console to the same guest-VM.

The serial multiplexer allows using several serial ports over a single physical serial link connection. In case that multiple users would like to connect to the guest-VM via serial-console, they should have such capability or at least be notified that someone is already using the connection, hence proceeding will drop the active session.

Version-Release number of selected component (if applicable):

Engine:
rhevm-3.6.0.3-0.1.el6.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch                                         
ovirt-engine-extension-aaa-jdbc-1.0.1-1.el6ev.noarch                 
ovirt-host-deploy-1.4.0-1.el6ev.noarch                                                  
ovirt-host-deploy-java-1.4.0-1.el6ev.noarch                                            
ovirt-vmconsole-1.0.0-1.el6ev.noarch

Host:
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-001-2.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-001-2.noarch


How reproducible:
100%

Steps to Reproduce:
1.Try to establish several serial-console connections to one guest-VM from same IP or from different IPs.
2.
3.

Actual results:
ssh -v -t -i $HOME/.ssh/id_dsa -p 2222 ovirt-vmconsole@engine's_IP connect
If trying to initiate second serial console connection from the same IP, then receiving:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is                                                                                        
6c:f4:1b:0e:93:7b:01:94:5b:83:d4:9b:c8:c2:65:8e.
Please contact your system administrator.
Add correct host key in /home/nsednev/.ssh/known_hosts to get rid of this message.
Offending RSA key in /home/nsednev/.ssh/known_hosts:2
RSA host key for [10.35.160.204]:2222 has changed and you have requested strict checking.
Host key verification failed.

If trying from another IP, then session is already busy and nothing actually happens:
Available Serial Consoles:
00 RHEL_7_2_VM2[3c0bb6b7-43e1-427c-9575-f58b50a72dae]
01 RHEL_7_2_VM2[3c0bb6b7-43e1-427c-9575-f58b50a72dae]
02 RHEL7_2_VM_1[ea857677-f6d2-4d16-a40a-a44222670482]
03 RHEL7_2_VM_1[ea857677-f6d2-4d16-a40a-a44222670482]
SELECT> 02



Expected results:
Each new connection should get it's own serial-console session or at least to have the ability to kick-off the active session, or to be notified that session is already occupied.

Additional info:
Problematic scenario from https://bugzilla.redhat.com/show_bug.cgi?id=1278466 was taken in consideration, while openening this RFE.
Comment 1 Alon Bar-Lev 2015-11-11 11:42:18 EST
this is not part of any known scope, may cause severe conflicts.
Comment 2 Nikolai Sednev 2015-11-29 00:18:46 EST
Please see comment #1 in https://bugzilla.redhat.com/show_bug.cgi?id=1070703.
Looks like requested functionality is required by customer.
Comment 3 Alon Bar-Lev 2015-11-29 02:45:18 EST
(In reply to Nikolai Sednev from comment #2)
> Please see comment #1 in https://bugzilla.redhat.com/show_bug.cgi?id=1070703.
> Looks like requested functionality is required by customer.

Again, it is not your role to tell what customer actually wants, nor to open RFEs on behalf of a customer.

You should also learn how to use bugzilla, use bug#1070703 comment#1 or bug 1070703 comment 1 to reference bugs.

Supporting serial console between guests is a different use case which is intentionally out of scope of this feature, as we repeatedly discussed.

Please reduce the noise by actually testing what we do provide no more and no less.

Note You need to log in before you can comment on or make changes to this bug.