Bug 1280394 - rhel-osp-director: 8.0 - unable to build the agent-ramdisk image.
rhel-osp-director: 8.0 - unable to build the agent-ramdisk image.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: beta
: 8.0 (Liberty)
Assigned To: Mike Burns
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 11:15 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: diskimage-builder-1.2.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-07 20:53:53 EDT

  None (edit)
Description Alexander Chuzhoy 2015-11-11 11:15:14 EST
rhel-osp-director: 8.0 - unable to build the agent-ramdisk image.


Environment:
instack-undercloud-2.1.3-1.el7ost.noarch
python-tripleoclient-0.0.11-5.el7ost.noarch

Steps to reproduce:
1. Deploy the undercloud
2. Attempt to build the images with "openstack overcloud image build --all"

Result:
ironic-python-agent.initramfs  doesn't get created.


Attempt to build just the agent-ramdisk type with: "openstack overcloud image build --type=agent-ramdisk"

Exits with error:
Could not open requirements file: [Errno 2] No such file or directory: '/tmp/ironic-python-agent/requirements.txt'

Expected result:
All the required images should be created with no issues.
Comment 2 Mike Burns 2015-11-11 12:19:08 EST
Need to pull in newer diskimage-builder.
Comment 4 Amit Ugol 2015-11-21 20:17:24 EST
I was able to build everything and later deploy using those images
Comment 6 errata-xmlrpc 2016-04-07 17:11:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.