Bug 1280419 - error "unsupported migration cookie feature memory-hotplug" is reported despite migration working
error "unsupported migration cookie feature memory-hotplug" is reported despi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.2
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Peter Krempa
Virtualization Bugs
: ZStream
Depends On: 1278404
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 12:16 EST by Jan Kurik
Modified: 2015-12-08 05:41 EST (History)
10 users (show)

See Also:
Fixed In Version: libvirt-1.2.17-13.el7_2.1
Doc Type: Bug Fix
Doc Text:
Cause: Improperly logged error message when migrating with memory hotplug enabled. Consequence: When migrating with memory hotplug enabled the destination host logged a spurious message saying "unsupported migration cookie feature memory-hotplug". This didn't break migration but in cases where the migration would fail for some other reason this would sidetrack from the real cause of the failure. Fix: The error message is suppressed by correctly parsing the migration cookie flags. Result:
Story Points: ---
Clone Of: 1278404
Environment:
Last Closed: 2015-12-08 05:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-11 12:16:12 EST
This bug has been copied from bug #1278404 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 6 yafu 2015-11-24 03:37:28 EST
Reproduce this bug with build:
libvirt-1.2.17-13.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64

1.Prepare two hosts for migration;

2.Configure the libvirtd.conf as below and restart libvirtd service on the destination host:
  #cat /etc/libvirt/libvirtd.conf
   log_level=1
   log_outputs="1:file:/var/log/libvirt/libvirtd.log"

  #service libvirtd restart

2.Prepare a guest with <maxMemory> set:
 #virsh dumpxml rhel7
  <maxMemory slots='16' unit='KiB'>152429568</maxMemory>
  ...
  <cpu>
    <numa>
      <cell id='0' cpus='0-3' memory='512000' unit='KiB'/>
      <cell id='1' cpus='4-7' memory='512000' unit='KiB'/>
    </numa>
  </cpu>
  ...

3.Do migration:
  #virsh migrate rhel7 qemu+ssh://10.66.4.148/system --live

4.Check the libvirtd.log on the destination host, could see the error "unsupported migration cookie feature memory-hotplug", so the bug reproduced.
  #tailf /var/log/libvirt/libvirtd.log
2015-11-24 03:21:21.383+0000: 12735: error : qemuMigrationCookieXMLParse:1224 : internal error: Unsupported migration cookie feature memory-hotplug



Verify this bug with build:
libvirt-1.2.17-13.el7_2.1.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64

1.Re-execute step 1-3 in reproduce steps

2.Re-check the libvirtd.log on the destination host, could not see the error "unsupported migration cookie feature memory-hotplug".

According to upper steps, mark this bug verified.
Comment 8 errata-xmlrpc 2015-12-08 05:41:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2567.html

Note You need to log in before you can comment on or make changes to this bug.