Bug 1280431 - [Director]External ceph configuration change from parameters to parameter_defaults
[Director]External ceph configuration change from parameters to parameter_def...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Dan Macpherson
Radek Bíba
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 12:43 EST by Ben Nemec
Modified: 2016-08-16 03:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 03:06:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed asciidoc changes (10.74 KB, patch)
2016-05-16 09:28 EDT, Radek Bíba
no flags Details | Diff

  None (edit)
Description Ben Nemec 2015-11-11 12:43:08 EST
Description of problem: After we merged the downstream version of external ceph, the upstream review determined that the parameters involved should not be top-level, and should instead be set with parameter_defaults.  Because we have customers using parameters today, we'll need a note on upgrades to 8.0 that explains the need to move those settings from the parameters section to the parameter_defaults section.

So an existing user might have a configuration that looks like:

parameters:
  CephClientUserName: openstack

This needs to be changed to:

parameter_defaults:
  CephClientUserName: openstack

This applies to any of the parameters in the environments/puppet-ceph-external.yaml file in tripleo-heat-templates.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Mike Burns 2015-11-20 07:51:52 EST
Just fyi, we need this change in for 8.0 GA.
Comment 4 Giulio Fidente 2016-02-17 06:42:59 EST
Currently the kbase article [1] does not mention explicitly use of parameters: or parameter_defaults: and suggests to edit the sample environment file which seems best approach to me. Maybe we can close this BZ?

1. https://access.redhat.com/articles/1994713
Comment 5 Dan Macpherson 2016-02-17 09:43:53 EST
Also, I should mention I'll be consolidating a lot of the Ceph/OpenStack information into a new guide for OSP 8.0. The article in comment #4 should only apply to 7.x for the moment, and when I write a draft of the new guide we can clarify the structure of the external Ceph environment file.
Comment 6 Ben Nemec 2016-03-07 10:13:41 EST
We will also need a note in the upgrade section for anyone using external ceph from before the change was made.  Otherwise it sounds like we're covered for this.
Comment 7 Deepak C Shetty 2016-03-07 23:36:00 EST
(In reply to Dan Macpherson from comment #5)
> Also, I should mention I'll be consolidating a lot of the Ceph/OpenStack
> information into a new guide for OSP 8.0. The article in comment #4 should
> only apply to 7.x for the moment, and when I write a draft of the new guide
> we can clarify the structure of the external Ceph environment file.

Just wanted to point out that for OSP 8.0 we are also planning to support hyper-converged compute+ceph setup. John Fulton from System Engg is working on the steps and doc for the same. Given you are consolidating ceph/openstack info ina new guide, I was hoping it would be good to document both (external ceph & converged ceph) setup in one guide, since both uses puppet-ceph-external.yaml. My 2 cents.

thanx,
deepak
Comment 10 John Fulton 2016-03-08 09:15:08 EST
(In reply to Deepak C Shetty from comment #7)
> (In reply to Dan Macpherson from comment #5)
> > Also, I should mention I'll be consolidating a lot of the Ceph/OpenStack
> > information into a new guide for OSP 8.0. The article in comment #4 should
> > only apply to 7.x for the moment, and when I write a draft of the new guide
> > we can clarify the structure of the external Ceph environment file.
> 
> Just wanted to point out that for OSP 8.0 we are also planning to support
> hyper-converged compute+ceph setup. 

Not exactly. The plan is for a hyper-converged compute+ceph setup to be available in OSP8 but by support exception only. 

> John Fulton from System Engg is working on the steps and doc for the same. 

I am working on this and will have a separate Reference Implementation. This bug is relevant for that work, so thanks for CC'ing me to it. 

> Given you are consolidating
> ceph/openstack info ina new guide, I was hoping it would be good to document
> both (external ceph & converged ceph) setup in one guide, since both uses
> puppet-ceph-external.yaml. My 2 cents.

I respectfully disagree. IMO our documentation for what is supported should not include a hyper-converged compute+ceph setup until it is fully supported. Also, please keep in mind the difference between Documentation and Reference Architectures.
Comment 11 Deepak C Shetty 2016-03-08 09:25:12 EST
> 
> > Given you are consolidating
> > ceph/openstack info ina new guide, I was hoping it would be good to document
> > both (external ceph & converged ceph) setup in one guide, since both uses
> > puppet-ceph-external.yaml. My 2 cents.
> 
> I respectfully disagree. IMO our documentation for what is supported should
> not include a hyper-converged compute+ceph setup until it is fully
> supported. Also, please keep in mind the difference between Documentation
> and Reference Architectures.

Thanks, clear now :)
Sorry for the noise.
Comment 15 Dan Macpherson 2016-03-16 00:24:15 EDT
Sent the Ceph Storage guide out for technical review. Switching Ceph bugs to POST.
Comment 16 Mike McCune 2016-03-28 18:29:36 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 17 Dan Macpherson 2016-04-29 02:42:33 EDT
Hi Ben,

The Ceph Storage Guide is out now. I've scanned through and it doesn't seem like we're using "parameters" for environment files.

https://access.redhat.com/documentation/en/red-hat-openstack-platform/version-8/red-hat-ceph-storage-for-the-overcloud/

Let me know if there's anything I should change in terms of the example environment files.
Comment 18 Dan Macpherson 2016-05-12 20:34:57 EDT
Hi Ben, Just following up... Any further changes required?
Comment 19 Ben Nemec 2016-05-13 15:27:49 EDT
We're fine on new installations because the sample file was changed.  The concern is anyone with external ceph upgrading from 7.x to 8 because their 7.x external-ceph environment file won't work in 8.  I think we probably want a note like the satellite one on https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/director-installation-and-usage/chapter-10-upgrading-the-environment about changing puppet-ceph-external.yaml to use parameter_defaults.
Comment 20 Andrew Dahms 2016-05-16 03:13:35 EDT
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?
Comment 21 Radek Bíba 2016-05-16 09:28 EDT
Created attachment 1157916 [details]
Proposed asciidoc changes

Looks wonderful. Attaching a few formatting and language improvements to consider. (At least the first formatting improvement is important because the affected text is now rendered as a single paragraph on the Portal.)
Comment 22 Dan Macpherson 2016-08-16 03:06:49 EDT
The feedback from Radek has been implemented and pushed live. Switching this to CLOSED.

Note You need to log in before you can comment on or make changes to this bug.