Bug 1280437 - Specify PIDFile in service file
Specify PIDFile in service file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: keepalived (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ryan O'Hara
Fedora Extras Quality Assurance
:
: 1334094 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 12:57 EST by Quentin Armitage
Modified: 2016-06-03 13:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 13:27:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2015-11-11 12:57:13 EST
Description of problem:
keepalived doesn't reliably shutdown

Version-Release number of selected component (if applicable):
keepalived-1.2.29-1

How reproducible:
Sometimes

Steps to Reproduce:
1. systemctl stop keepalived
2. ps -ef | grep keepalived - sometimes shows keepalived still running
3.

Actual results:
keepalived still running

Expected results:
keepalived no longer running

Additional info:
The man page for systemd.service recommends the use of PIDFile= should be set for services with Type=forking.
Adding PIDFile=/var/run/keepalived.pid to the service file appears to resolve the problem.
Comment 1 Ryan O'Hara 2016-01-23 03:01:10 EST
I could not reproduce this, but I've added PIDFile to the systemd unit file since it is recommended. Thanks for noticing this!
Comment 2 Ryan O'Hara 2016-06-03 09:45:30 EDT
*** Bug 1334094 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.