Bug 1280447 - Card reader not detected
Card reader not detected
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pcsc-lite (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 13:31 EST by Yajo
Modified: 2016-01-11 04:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 04:13:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yajo 2015-11-11 13:31:13 EST
Description of problem:
I have a card reader and inserted a cryptographic card. Nothing detected.


Version-Release number of selected component (if applicable):
opensc-0.14.0-2.fc22.x86_64


Steps to Reproduce:
1. Insert smart card.
2. Run opensc-tool --list-readers

Actual results:
No smart card readers found.


Expected results:
1 reader found.


Additional info:
The same reader reads some kinds of SD cards and has bluetooth, so I expect it to work for this too.

It could be a drivers issue, but I don't know where else to post this :S
Comment 1 Nikos Mavrogiannopoulos 2015-11-12 08:01:44 EST
The "driver" is pcscd (and pcsc-lite-ccid). Which card reader is that? The supported in ccid are shown below:
https://pcsclite.alioth.debian.org/ccid/supported.html

If it is one of the supported, what do you see in dmesg when you enter the card? What do you see with pcsc_scan?
Comment 2 Yajo 2015-11-17 13:40:12 EST
I installed pcsc-lite-ccid and rebooted (I found no pcscd package).

I'm not sure how to know the card reader type, but it seems pcsc_scan works (I removed numbers in case it matters for security):

PC/SC device scanner
V 1.4.23 (c) 2001-2011, Ludovic Rousseau <ludovic.rousseau@free.fr>
Compiled with PC/SC lite version: 1.8.13
Using reader plug'n play mechanism
Scanning present readers...
0: Generic USB2.0-CRW [Smart Card Reader Interface] ****

Tue Nov 17 19:28:10 2015
Reader 0: Generic USB2.0-CRW [Smart Card Reader Interface] ****
  Card state: Card inserted, 
  ATR: ****

defined(@array) is deprecated at /usr/lib64/perl5/vendor_perl/Chipcard/PCSC.pm line 69.
	(Maybe you should just omit the defined()?)
ATR: **** = 3B --> Direct Convention
+ T0 = 7F, Y(1): 0111, K: 15 (historical bytes)
  TA(1) = 38 --> Fi=744, Di=12, 62 cycles/ETU
    64516 bits/s at 4 MHz, fMax for Fi = 8 MHz => 129032 bits/s
  TB(1) = 00 --> VPP is not electrically connected
  TC(1) = 00 --> Extra guard time: 0
+ Historical bytes: ****
  Category indicator byte: 00 (compact TLV data object)
    Tag: 6, len: A (pre-issuing data)
      Data: ****
    Mandatory status indicator (3 last bytes)
      LCS (life card cycle): 03 (Initialisation state)
      SW: 9000 (Normal processing.)

Possibly identified card (using /usr/share/pcsc/smartcard_list.txt):
****
****
	DNI electronico (Spanish electronic ID card)
	http://www.dnielectronico.es


Also, after installing pcsc-tools, `opensc-tool --list-readers` shows:

# Detected readers (pcsc)
Nr.  Card  Features  Name
0    Yes             Generic USB2.0-CRW [Smart Card Reader Interface] (****) 00 00

So it seems the problem was the missing package.

And dmesg shows nothing.

Shouldn't these packages be autoinstalled or something like that to allow support for smart cards out of the box?
Comment 3 Nikos Mavrogiannopoulos 2015-11-18 03:30:31 EST
So it seems your missing software was "pcsc-lite-ccid" which contains the "drivers" for usb cards. pcsc-lite can work without it, but we don't provide any other driver. It would then make sense to add a "Recommends: pcsc-lite-ccid" to pcsc-lite. Any objections?
Comment 4 Yajo 2015-11-18 07:12:04 EST
Seems OK.

Note You need to log in before you can comment on or make changes to this bug.