Bug 1280518 - mupdf-1.8 is available
mupdf-1.8 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mupdf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 19:15 EST by Upstream Release Monitoring
Modified: 2015-11-28 08:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 08:27:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2015-11-11 19:15:37 EST
Latest upstream release: 1.8
Current version/release in rawhide: 1.7a-2.fc23
URL: http://mupdf.com/download/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-11-11 19:15:52 EST
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-lXvHuf/mupdf.spec
return code:  1
stdout:

stderr:
error: Bad source: ./mupdf-1.8-openjpeg.patch: No such file or directory
Comment 2 Pablo Rodríguez 2015-11-15 10:26:40 EST
(In reply to Upstream Release Monitoring from comment #1)
> Failed to kick off scratch build.
> 
> cmd:  rpmbuild -bs /var/tmp/thn-lXvHuf/mupdf.spec
> return code:  1
> stdout:
> 
> stderr:
> error: Bad source: ./mupdf-1.8-openjpeg.patch: No such file or directory

Pavel,

would it be possible that you rename mupdf-1.7a-openjpeg.patch to mupdf-openjpeg.patch and update the spec file accordingly?

Sorry, but this happens each time mupdf has to be rebuilt.

Many thanks for your help,

Pablo
Comment 3 Petr Šabata 2015-11-18 04:55:57 EST
That's because of the %{version} macro used on the Patch line; a bad practice, I would say.
Comment 4 Petr Šabata 2015-11-18 09:56:03 EST
I removed the %{version} macro in Rawhide, pushed as 1.7a-3.fc24.

I had to do a few more minor changes to make the package build again, namely manually packaging the documentation as %doc; rpm doesn't autopackage %{_docdir} automatically anymore.  I also marked the license text with %license, as mandated by the current guidelines.  There's more that could be done.

@Pavel,

I can help with the update and some more cleanup & modernization.  Let me know if you're interested.
Comment 5 Pablo Rodríguez 2015-11-21 16:30:10 EST
Petr,

would it be possible to command compilation of new released version upstream?

Many thanks for your help

Pablo
Comment 6 Petr Šabata 2015-11-23 10:27:08 EST
I'm sorry but what exactly do you mean by that?

If you want me to do the update -- sure, I'm willing but I'd like to hear from Pavel first.
Comment 7 Pavel Zhukov 2015-11-23 11:26:12 EST
(In reply to Pablo Rodríguez from comment #5)
> Petr,
> 
> would it be possible to command compilation of new released version upstream?
> 
> Many thanks for your help
> 
> Pablo

1.8 has some issues (warning as errors) and failed to build rawhide. Need some patching again.
Comment 8 Petr Šabata 2015-11-24 06:07:16 EST
(In reply to Pavel Zhukov from comment #7)
> 1.8 has some issues (warning as errors) and failed to build rawhide. Need
> some patching again.

Is that so?

I've just tried building in myself in f24 mock and it worked just fine.
Comment 9 Petr Šabata 2015-11-24 06:31:21 EST
A koji scratch build of 1.8:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11966030

Note You need to log in before you can comment on or make changes to this bug.