Bug 128058 - Deleting ppp options doesn't work correctly
Deleting ppp options doesn't work correctly
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2004-07-16 16:23 EDT by Bruno Wolff III
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.7-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-13 23:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2004-07-16 16:23:55 EDT
Description of problem:After adding the 'active-filter option' to
a ppp device and having the activate fail I tried to delete the option.
However the option remained in the config file.
Version-Release number of selected component (if applicable):

How reproducible:For my specific example 100%. I didn't try any varients though.

Steps to Reproduce:
1.Go in to network config and using edit add the option 'active-filter outbound' to a dialup ppp device
2.activate the device. You save the config as part of doing this. The activation will fail.
3.Delete the option and then try to activate the device again. The delete will
  look like it worked in network config, but the option won't get removed from the underlying device config file.
Actual results:Removing a ppp option appears to work in network config,
but the option remains in the config file.

Expected results:The option should get removed.

Additional info:
Comment 1 John Thacker 2006-10-29 17:00:16 EST
Changing version to correct one.  (test1 -> fc3test1, and some were filed as
test3 accidentally instead; but clearly must be fc3test1 given the date of filing.)
Comment 2 Christian Iseli 2007-01-22 06:55:53 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 3 Bruno Wolff III 2007-01-22 09:48:45 EST
I retested this in FC5 and things still work as described above.
Comment 4 Jiri Moskovcak 2008-02-01 06:03:46 EST
Fix commited to git repository. Should be available in next update.
Comment 5 John Poelstra 2008-05-13 21:08:24 EDT
can this bugs be closed based on the last comment?
Comment 6 Bug Zapper 2008-05-13 21:56:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 7 Bruno Wolff III 2008-05-13 23:38:41 EDT
Sorry I took so long to retest this.
Adding removing valid options works.
Adding active-filter outbound specifically works.
Adding bogus options doesn't always give you a warning right away in at least
one case results in the option not being saved without a warning. (This happened
when I used active filter outbound without the hypen.)
So the bug I reported is fixed, but sometimes you don't get warned about bad data.

Note You need to log in before you can comment on or make changes to this bug.