Bug 1280590 - Software updates applet ignores excludes in dnf.conf
Software updates applet ignores excludes in dnf.conf
Status: CLOSED DUPLICATE of bug 1256108
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 22:14 EST by Benedikt Gollatz
Modified: 2015-11-30 10:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 10:51:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benedikt Gollatz 2015-11-11 22:14:30 EST
Description of problem:
Packages that have been downgraded to a previous Fedora release and excluded from automatic updating by adding an exclude option to dnf.conf still appear as updates in the "Software updates" Plasma applet.


Version-Release number of selected component (if applicable):
plasma-pk-updates-0.2-5.fc23.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Downgrade some packages, say xorg-x11-server-* and xorg-x11-drv-* to the F22 build.
2. Add "exclude=xorg-x11-server-* xorg-x11-drv-*" to the [main] section of /etc/dnf/dnf.conf.
3. Verify that "dnf update" will not update these packages to the F23 version.


Actual results:
The applet will warn that there are a number of available software updates list the excluded packages for updating.


Expected results:
No listing of excluded packages by the "Software updates" Plasma applet.


Additional info:
I have observed that this behaviour persists even after the applet refreshes the metadata caches ("Last updated" timer in the applet resets).
Comment 1 Benedikt Gollatz 2015-11-12 12:58:20 EST
Unsurprisingly, plasma-pk-updates simply connects to PackageKit for information about package updates. Much to my surprise, however, the hawkey/libhif PackageKit backend completely bypasses DNF and goes to libsolv directly to perform its own dependency resolution.

I have found no documentation on how to configure package excludes either in PackageKit or the backend, but I feel such a feature should be available to advanced users. Presumably, configuring excludes should be possible independently of the backend, so I've chosen to move the bug to the PackageKit component.
Comment 2 Rex Dieter 2015-11-12 13:02:43 EST
One workaround, add excludes= entries to .repo files containing the packages you want skipped.

See also bug #1237014  (same topic)
Comment 3 Rex Dieter 2015-11-30 10:51:50 EST

*** This bug has been marked as a duplicate of bug 1256108 ***

Note You need to log in before you can comment on or make changes to this bug.