Bug 128060 - Installation aborted - because of unformatted partitions?
Installation aborted - because of unformatted partitions?
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-07-16 17:03 EDT by Felix Schwarz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-15 12:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda dump file (28.13 KB, text/plain)
2004-07-16 17:04 EDT, Felix Schwarz
no flags Details
I had some partitions unformatted, and it started complaining from the last one (/dev/hda15) (830.15 KB, text/plain)
2005-05-11 08:10 EDT, Aggelos
no flags Details

  None (edit)
Description Felix Schwarz 2004-07-16 17:03:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040510

Description of problem:
I tried to make a fresh install of Fedora but the installation was
aborted while anaconda was trying to find old root partitions. This
bug is also present in Fedora Core 1.

See the attached logs from anaconda.

I think this bug may have something to do with my partition layout.
Here is my partition scheme before installing Fedora:
hda1  - Windows NTFS
hda2  - unused space (unformated)
hda3  - ext2 with a minimal linux
hda4  - unused space (unformated, Fedora should be installed here)

After the anaconda aborts I used the Fedora rescue mode and formatted
hda2 and hda3 with ext2. With the newly formatted partitions
everything worked as expected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start Fedora installation

Actual Results:  Installation is aborted while Anaconda is searching
old installations.

Expected Results:  Anaconda should recognize that there are no old
Comment 1 Felix Schwarz 2004-07-16 17:04:23 EDT
Created attachment 101985 [details]
Anaconda dump file
Comment 2 Jeremy Katz 2004-07-17 15:04:11 EDT
Fixed in CVS.  Odd that a) the partition was mountable and b) it
looked like there was a file there.
Comment 3 Aggelos 2005-05-11 08:10:22 EDT
Created attachment 114241 [details]
I had some partitions unformatted, and it started complaining from the last one (/dev/hda15)

attached is the dump I saved in floppy, as prompted by anaconda

Note You need to log in before you can comment on or make changes to this bug.