Bug 1280715 - fops-during-migration-pause.t spurious failure
fops-during-migration-pause.t spurious failure
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1280428
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 22:26 EST by Dan Lambright
Modified: 2016-04-19 03:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1280428
Environment:
Last Closed: 2016-04-19 03:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-11-11 22:26:08 EST
+++ This bug was initially created as a clone of Bug #1280428 +++

Description of problem:

fops-during-migration-pause.t failed due to spurious error

Version-Release number of selected component (if applicable):


How reproducible:

spurious error

Steps to Reproduce:
1. run fops-during-migration-pause.t 
2. look for error in last two steps
3. if do not see, repeat

Actual results:

failure on last two steps

Expected results:

no failure

Additional info:

the file was moved so fast, that it finished before the pause CLI arrived.The pause should come in the middle of the data transfer. To make this slower, the file size can be increased.

--- Additional comment from Vijay Bellur on 2015-11-11 15:56:32 EST ---

REVIEW: http://review.gluster.org/12570 (tests: fix spurious error in fops-during-migration-pause.t) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-11 22:25:53 EST ---

COMMIT: http://review.gluster.org/12570 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 869b81fceabf3b9d5508665fc36fa7f98a4d4316
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Wed Nov 11 15:54:10 2015 -0500

    tests: fix spurious error in fops-during-migration-pause.t
    
    The test did not spend long enough time moving the file for the
    pause to occur simultaneously, leading to failure. Solution is
    to elongate that time by increasing the file size.
    
    Change-Id: I1727fa9e3f7a987dfa07dd5da44c68d3f17218d9
    BUG: 1280428
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12570
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
Comment 1 Vijay Bellur 2015-11-11 22:31:31 EST
REVIEW: http://review.gluster.org/12571 (tests: fix spurious error in fops-during-migration-pause.t) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-11-12 06:54:24 EST
COMMIT: http://review.gluster.org/12571 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit fe120d326fd850bbea8cc5c0b3a9ba2764289e75
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Wed Nov 11 15:54:10 2015 -0500

    tests: fix spurious error in fops-during-migration-pause.t
    
    The test did not spend long enough time moving the file for the
    pause to occur simultaneously, leading to failure. Solution is
    to elongate that time by increasing the file size.
    
    This is a backport of 12570
    
    > Change-Id: I1727fa9e3f7a987dfa07dd5da44c68d3f17218d9
    > BUG: 1280428
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-on: http://review.gluster.org/12570
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Joseph Fernandes
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I32c0271acebc7f33dea790b9b2bee62849c7b984
    BUG: 1280715
    Reviewed-on: http://review.gluster.org/12571
    Reviewed-by: Joseph Fernandes
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:47:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.