Bug 128079 - ntfs module not loading
ntfs module not loading
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 23:12 EDT by Marcus Schuetz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-17 00:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Schuetz 2004-07-16 23:12:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
I have been unsuccessful loading the ntfs module for the last few
kernel releases. 2.6.7-1.469 was the last one where it worked without
problems, ever since it failed. 

Version-Release number of selected component (if applicable):
2.6.7-1.492

How reproducible:
Always

Steps to Reproduce:
1. compile ntfs module & install
2. reboot
3.
    

Actual Results:  ntfs module is not loaded

Expected Results:  ntfs module should load

Additional info:


NTFS driver 2.1.15 [Flags: R/O MODULE].
Unable to handle kernel NULL pointer dereference at virtual address
00000034
 printing eip:
3ead17bf
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: nls_utf8 ntfs(U) dm_mod sd_mod usb_storage scsi_mod
usblp ehci_hcd ohci_hcd button battery asus_acpi ac nvidia(U) ipv6
ext3 jbd
CPU:    0
EIP:    0060:[<3ead17bf>]    Tainted: P
EFLAGS: 00010202   (2.6.7-1.492)
EIP is at ntfs_fill_super+0x11d/0x60f [ntfs]
eax: 00000000   ebx: 00000000   ecx: 00000001   edx: 00000092
esi: 3dfd246c   edi: 3dfd252c   ebp: 386ace30   esp: 381e3e8c
ds: 007b   es: 007b   ss: 0068
Process mount (pid: 2344, threadinfo=381e3000 task=38694db0)
Stack: 02309a10 00000000 35ae2000 385ddc34 386ace30 385ddc00 00000000
0216946b
       31616468 00000100 35ae4000 fffffff4 35ae4a44 3ead8c00 00000000
0000007b
       02349660 00000000 3dfbcc28 3ead8c00 3ead1cd0 35ae2000 3ead16a2
02169634
Call Trace:
 [<0216946b>] get_sb_bdev+0xe0/0x11c
 [<3ead1cd0>] ntfs_get_sb+0xe/0x11 [ntfs]
 [<3ead16a2>] ntfs_fill_super+0x0/0x60f [ntfs]
 [<02169634>] do_kern_mount+0x8a/0x13a
 [<02184839>] do_new_mount+0x61/0x90
 [<0218534c>] do_mount+0x178/0x190
 [<0215e824>] get_user_size+0x30/0x57
 [<02185824>] sys_mount+0x121/0x1f9
Code: 8b 40 34 85 c0 74 2b 0f b7 80 9e 01 00 00 66 85 c0 74 1f 0f
Comment 1 Warren Togami 2004-07-17 00:59:49 EDT
This is not our problem.  We do not supply the NTFS module, nor do we
support problems when non-Fedora/RedHat modules are added to the
kernel.  You must go upstream or to the ntfs linux project for help.

Note You need to log in before you can comment on or make changes to this bug.