Bug 12808 - rpm doesn't add packages to Name-Index
rpm doesn't add packages to Name-Index
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-22 08:44 EDT by teichman
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 16:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description teichman 2000-06-22 08:44:14 EDT
When I first installed rpm-4.0 I tried to rebuild my database.
It didn't do this correctly at all, because afterwards I couldn't
query any package anymore (e. g. rpm -q bash responded
package bash not installed) I tried to do rpm -q -a and it
worked as I expected: it printed correctly all the packages
installed on my system (even bash).

An interesting Point is that in /var/lib/rpm no file seemed to be touched
but the file Package. rpm seems to forget to update all files.
Comment 1 Jeff Johnson 2000-06-22 08:57:54 EDT
What version of rpm, beta1 rpm-4.0-0.33 or some such? Look for (at least)
rpm-4.0-0.38 (currently I'm at -0.42, 0.43 expected soon), and do a --rebuilddb.
There's also a change from db3 (3.0.55) to db3 (3.1.4) in going from
beta1 to beta2, so you might instead need to do
	(with current rpm-4.0)
	rpm --rebuilddb -v --rebuilddbapi 1	# convert db3(3.0.55) to db1
	rpm -Uvh rpm-* popt-*			# upgrade to beta2 rpm
	rpm --rebuilddb -v			# convert db1 to db3(3.1.14)
	(expect some error messages here)
	rpm --rebuilddb -v			# should be clean rebuild
	rpm -Uvh rpm-* popt-* --force		# reinstall damaged headers
Apologies for the inconvenience.
Comment 2 Jeff Johnson 2000-06-22 08:58:46 EDT
Ooops, you will need to install the beta2 rpm by doing
	rpm -Uvh rpm-* popt-* --dbapi 1
Comment 3 teichman 2000-06-22 09:29:57 EDT
But where in world do I get rpm-4.0-0.42? According to the source
it should be found on ftp.rpm.org/pub/rpm, but there isn't even rpm-4.0-0.33,
which is shipped with the current rawhide. (This is at least a documentation
error...)
Comment 4 Hardy Mayer 2000-06-22 16:49:47 EDT
I installed rpm-3.05-3 (from rpm.org), which, as far as I can tell, does
everything correctly, including opening v. 4 rpm-s, and updating the database. 

I then tried to use rpm-4.0-0.33.i386.rpm, which has one nice feature (it tells
you which entry is added or subtracted from the database), but thoroughly messes
up the database (for example it still lists rpm-3.0.5-3 as installed after
installing  rpm-4.0-0.33.i386.rpm !!!

It would be nice if the rawhide-releases and the rpm.org/test releases were
coordinated.
Comment 5 Jeff Johnson 2000-06-22 17:43:33 EDT
rpm-4.0 has not been released, all rpm builds less than -0.38 have serious
problems. Furthermore, be forewarned: even though rpm builds > -0.38 appear to
be stable, there may be more breakage ahead.

There's also little chance that Raw Hide and ftp.rpm.org can be synchronized,
as the two machines serve very different purposes.

Note You need to log in before you can comment on or make changes to this bug.