Bug 128099 - Can't boot after yum update -- "Read-only filesystem"
Summary: Can't boot after yum update -- "Read-only filesystem"
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-17 18:22 UTC by Luke Hutchison
Modified: 2014-03-17 02:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 18:34:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luke Hutchison 2004-07-17 18:22:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux 2.4.26; X11) (KHTML, like Gecko)

Description of problem:
I just updated from FC2 to FC3-Test1 (actually, to the Fedora development RPMs).

I now get several errors after booting, saying that services can't be started because the filesystem is read-only.

Eventually I get a terminal login prompt.  "cat /etc/mtab" says that "/" is mounted "rw", yet nothing can be written to it.  I don't know how to try to unmount it and re-mount it in rw mode, since it is the root filesystem.

Any help, as soon as possible, would be greatly appreciated please -- I just rendered my primary machine useless :-|


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(Upgrade to Fedora-development RPMs)


Additional info:

Comment 1 Luke Hutchison 2004-07-17 19:14:17 UTC
Interesting tidbit: booting from Arjan's kernel-2.6.7-1.471 has no
problem; booting from Fedora-development kernel-2.6.7-1.488 does not work.

Comment 2 Luke Hutchison 2004-07-17 19:16:06 UTC
...so I do have a working system now -- thanks.  I left the ".488"
kernel in there, so I can run any tests you need me to to trace the
source of the problem.



Comment 3 Bill Nottingham 2004-07-20 16:34:38 UTC
What's the output of dmesg after booting 1.488?

Does 1.49x work better?

Comment 4 Luke Hutchison 2004-07-22 05:00:38 UTC
Unfortunately, 1.488 now boots fine, so I can't run dmesg.  I don't
know what fixed it.  Perhaps booting into Arjan's kernel somehow reset
some erroneous state in a file somewhere.  It is odd though that mtab
said "rw" but the errors I was getting said the partition was mounted
read-only.

I did skim through the dmesg output originally when I had the problem,
and I didn't see anything suspicious, but I may have missed something.

As I can't duplicate the problem currently, feel free to close this
bug report if it is no longer useful.


Comment 5 Bill Nottingham 2004-07-22 18:34:48 UTC
OK, closing for now.


Note You need to log in before you can comment on or make changes to this bug.