Bug 1281044 - Error was encountered while opening journal files: No data available
Error was encountered while opening journal files: No data available
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 22:54 EST by Steve
Modified: 2015-11-17 10:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 10:41:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2015-11-11 22:54:11 EST
Description of problem:
Error was encountered while opening journal files: No data available

Version-Release number of selected component (if applicable):
systemd-222-8.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. Open Terminal
2. Type "journalctl"
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Synacek 2015-11-12 08:38:46 EST
With this amount of information, nobody can really do anything about your problem.

What does "ls /var/log/journal/*" show? Is SELinux on? If yes, does the problem disappear after "setenforce 0"?
Comment 3 Jan Synacek 2015-11-13 03:10:44 EST
Try running "journalctl --verify".
Comment 4 Steve 2015-11-13 03:21:46 EST
$ journalctl --verify
Error was encountered while opening journal files: No data available
$ sudo journalctl --verify
Error was encountered while opening journal files: No data available
$
Comment 5 Steve 2015-11-14 11:57:36 EST
After some research, i found this:

$ sudo rpm -Va systemd
.M.......    /var/log/journal

(Code M means:  File mode differs.)

The actual file mode is:
8 drwxr-sr-x+  3 root   systemd-journal     4096 Oct 19 09:13 journal

Is something wrong here?
Comment 6 Steve 2015-11-16 10:10:04 EST
This seems to be a known bug: 

https://bbs.archlinux.org/viewtopic.php?id=199411
https://github.com/systemd/systemd/issues/487
...

However, i found a workaround:

$ sudo rm -rf /var/log/journal/
$ reboot

After reboot, systemd will automatically create new journal files.
Comment 7 Steve 2015-11-17 00:22:00 EST
The right permissions are:

4 drwxr-sr-x.  2 root   systemd-journal     4096 Nov 17 06:16 journal

Note You need to log in before you can comment on or make changes to this bug.