Bug 128113 - Screen resolution changes everytime system boots
Screen resolution changes everytime system boots
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-18 09:42 EDT by Srinivas
Modified: 2014-06-18 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 16:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg config file (2.93 KB, text/plain)
2004-07-18 09:43 EDT, Srinivas
no flags Details
Xorg log file (41.78 KB, text/plain)
2004-07-18 09:44 EDT, Srinivas
no flags Details
This is my Xorg log when its not working (39.50 KB, text/plain)
2005-09-16 20:15 EDT, Carl Parrish
no flags Details
This is my Xorg.conf file (2.84 KB, text/plain)
2005-09-16 20:16 EDT, Carl Parrish
no flags Details

  None (edit)
Description Srinivas 2004-07-18 09:42:06 EDT
Description of problem:
I did a fresh install of FC2 on my DELL Dimension 8100 desktop with
ATI RADEON 7200 graphics card and Sun 21" monitor (Sony GDM-20E20). In
the window manager I can set the resolution to 1600x1200@65Hz which
works great as long as I don't reboot the box.

When I reboot the box screen goes blank during "start-up" and the
"login screen". Since I setup to "auto login" I do get the window
manager to display but only in 1152x864. I will have to manually
change resolution back to 1600x1200 everytime.



Version-Release number of selected component (if applicable):
system-config-display-1.0.14-1

How reproducible:
everytime

Steps to Reproduce:
1. install FC2
2. Set screen resolution to 1600x1200
3. reboot
  
Actual results:


Expected results:


Additional info:
Comment 1 Srinivas 2004-07-18 09:43:37 EDT
Created attachment 102016 [details]
Xorg config file
Comment 2 Srinivas 2004-07-18 09:44:21 EDT
Created attachment 102017 [details]
Xorg log file
Comment 3 Paul Nasrat 2004-08-09 06:24:26 EDT
Are you setting the resolution using Preferences->Screen Resolution? 
That's using xrandr to set the resolution up.

Thanks for the conf/log file - investigating

Comment 4 Srinivas 2004-08-09 08:26:10 EDT
Yes and I also used "display" settings too with the same results.
I think both utilities update /etc/X11/xorg.conf.

Thanks for all your help.

Comment 5 Paul Nasrat 2004-08-09 09:11:32 EDT
No preferences->screen resolution does not update the config it uses
xrandr to dynamically change resolution.

Just to confirm, the attached config file and logs are after setting
up resolution to 1600x1200 using system-config-display and booting?
Comment 6 Srinivas 2004-08-09 19:01:12 EDT
yes.
Comment 7 Paul Nasrat 2004-09-14 07:05:17 EDT
Can you attach the output of xrandr -q

Is there an option in Preferences->Screen Resolution for 1600x1200
@75Hz as this is what X is trying to set and failing.
Comment 9 Mike A. Harris 2004-09-14 07:21:44 EDT
The attached log is from an X server configured to start up in
1600x1200 resolution, which is correctly starting up in 1600x1200.

If you're sometimes experiencing it not starting up in 1600x1200, then
we need an X server log file from when it starts up in a different
resolution.  Whatever is causing it to not start in 1600x1200 will
be present in the log file.  Comparing the two will show the problem
generally.

The current log file attached here says "1600x1200 works fine"
though.  Can you attach log from failed startup?

Comment 10 Carl Parrish 2005-09-16 08:13:46 EDT
I'm running into the same problem but on FC4. This is a new problem for me. (or
seems to be) I don't have to restart that often but about 2 weeks ago this
started happening and I've noticed on reach reboot that I have to reset my
resolution. 
Comment 11 Carl Parrish 2005-09-16 20:15:24 EDT
Created attachment 118921 [details]
This is my Xorg log when its not working 

When I reboot my system it comes in at a resolution of 1600X1200 even though I
change it and set as my default 1280X1024. This is what my Xorg log looks like
before the switch
Comment 12 Carl Parrish 2005-09-16 20:16:59 EDT
Created attachment 118922 [details]
This is my Xorg.conf file 

I'm including my xorg.conf in the hopes that this helps.
Comment 13 Mike A. Harris 2005-09-23 02:33:28 EDT
Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
"1600x1200"
	EndSubSection
EndSection

Remove "1600x1200" from the end of the list there.  Does the problem go away
now?
Comment 14 John Thacker 2006-04-24 16:27:55 EDT
Closing due to lack of response from reporter.

Note You need to log in before you can comment on or make changes to this bug.