This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1281220 - UI indicates that you can delete Default Location
UI indicates that you can delete Default Location
Status: CLOSED DUPLICATE of bug 1268012
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Ohad Levy
Katello QA List
David O'Brien
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 23:59 EST by David O'Brien
Modified: 2015-11-16 14:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 14:03:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2015-11-11 23:59:09 EST
Description of problem:

Navigate to Administer > Locations
For "Default Location" click "Delete"

UI returns error saying "can't delete default Location"

Version-Release number of selected component (if applicable):

6.1.3

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

If it's not slated to be addressed in a later release, it would be an improvement if the "Delete" option were removed so as not to confuse users.

Additional info:
Comment 1 David O'Brien 2015-11-12 00:28:48 EST
Not sure if I should raise this separately, but from the CLI perspective:

# hammer location delete --id 5

Could not delete the location:
  Cannot delete the default Location

If there is no indication in the location name that it's the default, it too could lead to confusion. Would it be possible to do something like:

# hammer location list

5  | Red Hat (default)
Comment 2 Brad Buckingham 2015-11-16 14:03:36 EST

*** This bug has been marked as a duplicate of bug 1268012 ***

Note You need to log in before you can comment on or make changes to this bug.