This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1281230 - dht must avoid fresh lookups when a single replica pair goes offline
dht must avoid fresh lookups when a single replica pair goes offline
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sakshi
: Triaged
Depends On:
Blocks: 1283972 1330901
  Show dependency treegraph
 
Reported: 2015-11-12 00:57 EST by Sakshi
Modified: 2016-07-31 21:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283972 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2015-11-12 00:57:32 EST
Description of problem:
Currently even if a single replica pair goes down, there will be fresh lookups for all files and directories thought there is no layout changes. Hence DHT must avoid fresh lookups when bricks go down.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a 2x2 dist-rep volume, mount the volume and create few directories.
2. Bring one the replica pair down.
3. Perform lookup on the directories

Actual results:
Fresh lookups on all the directories

Expected results:
Fresh lookup must be avoided, and read xattr from the other pair

Additional info:
Comment 1 Vijay Bellur 2015-11-12 02:00:59 EST
REVIEW: http://review.gluster.org/12573 (afr: replica pair going offline does not require CHILD_MODIFIED event) posted (#1) for review on master by Sakshi Bansal
Comment 2 Vijay Bellur 2015-11-12 04:09:27 EST
REVIEW: http://review.gluster.org/12573 (afr: replica pair going offline does not require CHILD_MODIFIED event) posted (#2) for review on master by Sakshi Bansal
Comment 3 Vijay Bellur 2015-11-16 08:43:25 EST
COMMIT: http://review.gluster.org/12573 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 3f0c70f2d56743707699f6a5b62a1c2c2d5c6f85
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Thu Nov 12 12:28:53 2015 +0530

    afr: replica pair going offline does not require CHILD_MODIFIED event
    
    As a part of CHILD_MODIFIED event DHT forgets the current layout and
    performs fresh lookup. However this is not required when a replica pair
    goes offline as the xattrs can be read from other replica pairs. Hence
    setting different event to handle replica pair going down.
    
    Change-Id: I5ede2a6398e63f34f89f9d3c9bc30598974402e3
    BUG: 1281230
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/12573
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Susant Palai <spalai@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:44:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.