Bug 1281257 - Fail to start master service if the names of certificate begin with "*"
Fail to start master service if the names of certificate begin with "*"
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 02:46 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-11-12 02:46:50 EST
Description of problem:
Fail to start master service if the names of certificate begin with "*"

Version-Release number of selected component (if applicable):
https://github.com/openshift/openshift-ansible master

How reproducible:
Always


Steps to Reproduce:

1. Install env with custom ca file
openshift_master_named_certificates=[{"certfile": "custom2.crt", "keyfile": "custom2.key", "names": ["test.custom.com","test1.custom.com"]}, {"certfile": "/root/custom1.crt", "keyfile": "/root/custom1.key"}]
 
 #openssl x509 -in custom2.crt -noout -text|egrep -i "issue"
        Issuer: C=86, ST=BJ, L=BeiJing, O=redhat, OU=apc, CN=*.openshift.redhat.com/emailAddress=test@redhat.com



Actual results:
Can not start master service

F1112 15:25:56.587368   18265 start_master.go:101] yaml: line 32: did not find expected alphabetic or numeric character


Expected results:
Start the master service successfully

Additional info:
#vim /etc/origin/master/master-config.yaml
 17 corsAllowedOrigins:
<--snip-->
 32   - openshift
 33   - *.openshift.redhat.com
 34   - *.test.redhat.com
 35 dnsConfig:
Comment 1 Andrew Butcher 2015-11-18 09:15:32 EST
Proposed fix is here: https://github.com/openshift/openshift-ansible/pull/881
Comment 2 Ma xiaoqiang 2015-11-18 20:39:52 EST
Get expected result, move it to VERIFIED
Comment 4 errata-xmlrpc 2015-12-17 16:19:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.