Bug 1281290 - Bad path for 'atomic uninstall' LABEL in cockpit-ws-docker image
Bad path for 'atomic uninstall' LABEL in cockpit-ws-docker image
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit-ws-docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stef Walter
Jan Ščotka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 04:11 EST by Stef Walter
Modified: 2015-11-19 18:28 EST (History)
5 users (show)

See Also:
Fixed In Version: cockpit-ws-docker-0.77-6
Doc Type: Bug Fix
Doc Text:
Previously, the `LABEL UNINSTALL` path in the cockpit-ws-docker image was incorrect. This bug fixes the path, and the image now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:28:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2015-11-12 04:11:48 EST
Description of problem:

The path in cockpit-ws-docker image uninstall LABEL is incorrect:

LABEL UNINSTALL /usr/bin/docker run -ti --rm --privileged -v /:/host IMAGE /cockpit/atomic-uninstall

It should be /container/atomic-uninstall

Version-Release number of selected component (if applicable):

cockpit-ws-docker 0.77-5
Comment 1 Stef Walter 2015-11-12 04:13:19 EST
This is the change that will fix this:

diff --git a/Dockerfile b/Dockerfile
index 69a0986..e281f82 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -20,7 +20,7 @@ RUN chmod -v +x /container/atomic-run
 RUN rm -f /etc/os-release /usr/lib/os-release && ln -sv /host/etc/os-release /etc/os-release && ln -sv /host/usr/lib/os-release /usr/lib/os-release
 
 LABEL INSTALL /usr/bin/docker run -ti --rm --privileged -v /:/host IMAGE /container/atomic-install
-LABEL UNINSTALL /usr/bin/docker run -ti --rm --privileged -v /:/host IMAGE /cockpit/atomic-uninstall
+LABEL UNINSTALL /usr/bin/docker run -ti --rm --privileged -v /:/host IMAGE /container/atomic-uninstall
 LABEL RUN /usr/bin/docker run -d --privileged --pid=host -v /:/host IMAGE /container/atomic-run --local-ssh
Comment 8 errata-xmlrpc 2015-11-19 18:28:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2488.html

Note You need to log in before you can comment on or make changes to this bug.