Bug 1281299 - Recent deployment isn't visible in RHCI Installer -> Deployments page
Recent deployment isn't visible in RHCI Installer -> Deployments page
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Erik Nelson
Thom Carlin
: Triaged
Depends On:
Blocks: rhci-sprint-16 qci-sprint-17
  Show dependency treegraph
 
Reported: 2015-11-12 04:25 EST by Antonin Pagac
Modified: 2016-09-13 12:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:22:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First Deployment (17.35 KB, image/png)
2016-06-24 11:52 EDT, Erik Nelson
no flags Details
Second Deployment (20.92 KB, image/png)
2016-06-24 11:53 EDT, Erik Nelson
no flags Details

  None (edit)
Description Antonin Pagac 2015-11-12 04:25:02 EST
Description of problem:
I have successfully finished a deployment of rhev+cfme. When I click RHCI Installer -> Deployments, the deployment isn't there, I can see my previous deployment but not the most recent one. I can go back in browser and work with the recent deployment with no problems, it just isn't showing in the Deployments page.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151104.t.0

How reproducible:
?

Steps to Reproduce:
1. Have one deployment finished, start another one
2. Finish the second deployment
3. Click RHCI Installer -> Deployments, the second deployment isn't there

Actual results:
Most recent deployment not visible on the Deployments page

Expected results:
All deployments visible on the Deployments page

Additional info:
I have also previously deleted a couple of failed deployments, that may also have something to do with this.
Comment 1 Antonin Pagac 2015-11-12 04:28:12 EST
When I refreshed the Deployments page my deployment appeared and is now visible.
Comment 2 Erik Nelson 2016-06-24 11:52:08 EDT
First RHEV+CFME deployment:
- Click Next from 100% successful review.progress
- Click "View Deployments", deployment is visible with "stopped"
See attached: firstdeployment.png

Second deployment:
- Same process, Next, then "View Deployments"
- Second deployment displays okay
See attached: seconddeployment.png

Did a page refresh, deployments display correctly.

It's possible this has been fixed since the bz was filed.
Comment 3 Erik Nelson 2016-06-24 11:52 EDT
Created attachment 1171988 [details]
First Deployment
Comment 4 Erik Nelson 2016-06-24 11:53 EDT
Created attachment 1171989 [details]
Second Deployment
Comment 5 Thom Carlin 2016-07-01 09:14:35 EDT
Verified in QCI 1.2

Also see deployments visible with "stopped"

Please reopen if this reoccurs
Comment 11 errata-xmlrpc 2016-09-13 12:22:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.