Bug 1281305 - dnf overzealously discard cache during system-upgrade
dnf overzealously discard cache during system-upgrade
Status: CLOSED DUPLICATE of bug 1276886
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 04:36 EST by Arnaud Lacombe
Modified: 2015-11-12 09:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 09:58:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Lacombe 2015-11-12 04:36:43 EST
Description of problem:
When trying to upgrade from Fedora 23 from Fedora 22, if dnf encounters an error, trying to run *any* dnf command to fix the issue will discard the cache. My upgrade is downloading for the third time, and it is EXTREMELY frustrating.

Re-downloading is not only a waste of bandwidth, but a complete utter waste of time. I've got 3 machines to upgrade, it's gonna be a huge pain...

This is a regression over previous system upgrade using fedup.

Version-Release number of selected component (if applicable): 22

How reproducible: always

Steps to Reproduce:
1. dnf system-upgrade download --releasever=23
2. dnf encounter a conflict
3. use dnf to resolve the conflict

Actual results:
Downloaded cache is discarded.

Expected results:
Downloaded cache is kept.

Additional info:
Comment 1 Arnaud Lacombe 2015-11-12 04:37:44 EST
The description should read: "from Fedora 22 to Fedora 23". Sorry for the typo.
Comment 2 Arnaud Lacombe 2015-11-12 05:01:25 EST
FWIW /etc/dnf/dnf.conf has a 'keepcache' options, but changing the configuration file seems overkill for what should be a temporary behavior.

How about introducing a --keepcache option to dnf ?
Comment 3 Will Woods 2015-11-12 09:58:09 EST

*** This bug has been marked as a duplicate of bug 1276886 ***

Note You need to log in before you can comment on or make changes to this bug.