Bug 1281312 - [RFE] ABRT emails format should be configurable
Summary: [RFE] ABRT emails format should be configurable
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: abrt
QA Contact: Martin Kyral
Maxim Svistunov
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 1289025 1305230
TreeView+ depends on / blocked
 
Reported: 2015-11-12 09:50 UTC by Steeve Goveas
Modified: 2016-11-04 03:08 UTC (History)
7 users (show)

Fixed In Version: abrt-2.1.11-36.el7
Doc Type: Enhancement
Doc Text:
Format of emails sent by *ABRT* is now configurable You can now configure the format of emails sent by *ABRT* using the new "-F FORMAT_FILE" command-line option of the *reporter-mailx* utility. This option allows you to define your own format. Without the "-F" option, *reporter-mailx* uses the default format, which sorts all important elements by importance. For more information about the format of formatting files, see the *reporter-mailx(1)* man page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:08:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch1 (2.27 KB, patch)
2016-04-18 15:36 UTC, Matej Habrnal
no flags Details | Diff
Patch2 (12.73 KB, patch)
2016-04-18 15:36 UTC, Matej Habrnal
no flags Details | Diff
Patch3 (942 bytes, patch)
2016-04-18 15:37 UTC, Matej Habrnal
no flags Details | Diff
Patch4 (4.85 KB, patch)
2016-04-18 15:37 UTC, Matej Habrnal
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2307 normal SHIPPED_LIVE abrt, gnome-abrt, and libreport bug fix and enhancement update 2016-11-03 13:40:24 UTC

Description Steeve Goveas 2015-11-12 09:50:43 UTC
Description of problem:
In abrt emails single line files precede multi-line files and multi-line files are displayed in alphabetical order. So contents of reporter_to are shown towards the end of the email report. If the backtrace is too long, this leads to scrolling all the way to the end of the email. The work around for this, is to rename files like reported_to to a name starting with "a".
I'm renaming it to abrt-faf-report to make it list before backtrace. If possible we should be able to configure the format to provide desired information in the first few lines of the email.

Version-Release number of selected component (if applicable):
abrt-2.1.11-34.el7.x86_64

Comment 2 Matej Habrnal 2016-04-18 15:36 UTC
Created attachment 1148246 [details]
Patch1

Comment 3 Matej Habrnal 2016-04-18 15:36 UTC
Created attachment 1148247 [details]
Patch2

Comment 4 Matej Habrnal 2016-04-18 15:37 UTC
Created attachment 1148248 [details]
Patch3

Comment 5 Matej Habrnal 2016-04-18 15:37 UTC
Created attachment 1148250 [details]
Patch4

Comment 6 Matej Habrnal 2016-04-18 15:40:08 UTC
related rhel7 testcase: https://github.com/abrt/abrt/tree/rhel7/tests/runtests/mailx-reporting

Comment 12 errata-xmlrpc 2016-11-04 03:08:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2307.html


Note You need to log in before you can comment on or make changes to this bug.