Bug 1281318 - gap between scheduler selection and claim causes spurious failures when the instance is the last one to fit
gap between scheduler selection and claim causes spurious failures when the i...
Status: CLOSED DUPLICATE of bug 1257950
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
:
Depends On:
Blocks: 1339506
  Show dependency treegraph
 
Reported: 2015-11-12 04:54 EST by Jaison Raju
Modified: 2016-05-25 04:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 08:40:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1341420 None None None Never
OpenStack gerrit 226235 None None None Never

  None (edit)
Description Jaison Raju 2015-11-12 04:54:44 EST
Description of problem:
There is a race between the scheduler in select_destinations, which selects a set of hosts, and the nova compute manager, which claims resources on those hosts when building the instance. The race is particularly noticable with Ironic, where every request will consume a full host, but can turn up on libvirt etc too. Multiple schedulers will likely exacerbate this too unless they are in a version of python with randomised dictionary ordering, in which case they will make it better .

Version-Release number of selected component (if applicable):
OSP7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
https://bugs.launchpad.net/nova/+bug/1341420
https://review.openstack.org/#/c/226235/
Comment 3 Mike Burns 2015-11-12 08:02:43 EST
How is this different from bug 1257950?  It looks like a duplicate to me.
Comment 4 Mike Burns 2015-11-12 08:40:13 EST

*** This bug has been marked as a duplicate of bug 1257950 ***

Note You need to log in before you can comment on or make changes to this bug.