Bug 128133 - include libpython.so in python package
include libpython.so in python package
Status: CLOSED DUPLICATE of bug 127357
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 01:26 EDT by Satish Balay
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2004-07-19 01:26:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Epiphany/1.0.8

Description of problem:
Curently pacakged python package does not have libpython.so

Version-Release number of selected component (if applicable):
python-2.3.4-4.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql python |grep libpython
2. ldd /usr/bin/python
3.
    

Actual Results:  no shared library for libpython

Expected Results:  have a shared library version

Additional info:

- calling python code from C  and creating a shared library for this
module requires libpython.so
- being able to call this module from /usr/bin/pyton requires
/usr/bin/python to be linked with the same libpython.so

Could you build python package to include the shared library version
of libpython.so - perhpas in FC3?
Comment 1 Mihai Ibanescu 2004-07-19 10:57:06 EDT

*** This bug has been marked as a duplicate of 127357 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.