Bug 128135 - Harddisk install failed
Harddisk install failed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 02:58 EDT by Pedro Fernandes Macedo
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 13:14:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Fernandes Macedo 2004-07-19 02:58:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Trying to install FC3T1, md5 checked on all isos. Burnt cd1 , placed
the isos on /dev/hdc1 (fat 32 partition) , in a folder called
Isos/Fedora/FC3test1/ .
After booting with linux askmethod selinux=0 xfs jfs hde=noprobe
hdf=noprobe hdg=noprobe hdh=noprobe , I got a failure message when I
selected the right directory and device , saying that the iso files
werent found. Switching to the other terminal, there was this message:
<4> VFS: Can't find ext2 filesystem on dev hdc1
<4> Unable to load NLS charset ascii
<3> fat: IO charset ascii not found

I decided to give another try and copied the isos to my home xfs
partition (dont have any ext2/3 partitions here..). Again , same
options and same error...

This same fat partition has been used to install all the fedora stable
and test releases since fedora core 1 on my computer , so I doubt
that's an error with the disk.

Version-Release number of selected component (if applicable):
fedora core 3 test 1

How reproducible:
Always

Steps to Reproduce:
1. place isos on a fat filesystem
2. Try to do a hard disk install
3.
    

Actual Results:  Fails to mount the device and open the isos

Expected Results:  Should open the isos correctly
Comment 1 Jim Cornette 2004-07-19 07:12:37 EDT
As a note to something related to vfat partions. I had failure with
the install when trying to mount a vfat volume upon install. I first
had a failure trying to upgrade an FC2 version to FC3T1. This halted
the installer for problems related to a bad vfat partion.

When I tried an install after reformatting the whole disk, creating a
vfat partition with w98. I had trouble similar to what Pedro encountered.

I know he was trying to install from the vfat partition, but it would
not mount either. (such as /mnt/vfat)
Comment 2 Jeremy Katz 2004-07-19 13:14:29 EDT
This is fixed in rawhide.  Caused by the charset modules for the
default FAT charset being modular instead of built-in.

Note You need to log in before you can comment on or make changes to this bug.