Bug 1281370 - MySql is crashing in reload_acl_and_cache at the time of calling rotate_relay_log.
MySql is crashing in reload_acl_and_cache at the time of calling rotate_relay...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql (Show other bugs)
6.8
x86_64 Linux
urgent Severity medium
: rc
: 6.8
Assigned To: Jakub Dorňák
Karel Volný
: Patch, ZStream
Depends On:
Blocks: 1312274
  Show dependency treegraph
 
Reported: 2015-11-12 07:02 EST by Mohit Agrawal
Modified: 2016-05-10 21:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when the rotate_relay_log() function was called, an unresolved concurrent access to a shared resource occurred. As a consequence, MySQL terminated unexpectedly with a segmentation fault. To fix this bug, a mutex lock on the resource is now used during the rotate_relay_log() call, and MySQL no longer crashes in this scenario.
Story Points: ---
Clone Of:
: 1312274 (view as bug list)
Environment:
Last Closed: 2016-05-10 21:34:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of all mysqld threads at the time of crash (187.25 KB, text/plain)
2015-11-12 07:08 EST, Mohit Agrawal
no flags Details

  None (edit)
Description Mohit Agrawal 2015-11-12 07:02:17 EST
Description of problem:
MySql is crashing in reload_acl_and_cache at the time of calling rotate_relay_log.

Version-Release number of selected component (if applicable):
mysql-server-5.1.73-3.el6_5.x86_64
mysql-5.1.73-3.el6_5.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Mysql is crashing.

Expected results:
MySql should not crash.

Additional info:
Comment 2 Mohit Agrawal 2015-11-12 07:08 EST
Created attachment 1093219 [details]
backtrace of all mysqld threads at the time of crash
Comment 17 errata-xmlrpc 2016-05-10 21:34:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0979.html

Note You need to log in before you can comment on or make changes to this bug.