Bug 1281457 - [RFE] possibility to configure software raid1 automatically during deployment
[RFE] possibility to configure software raid1 automatically during deployment
Status: CLOSED DUPLICATE of bug 1317918
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ga
: 11.0 (Ocata)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: FutureFeature, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 09:57 EST by Ondrej
Modified: 2016-11-10 06:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 06:48:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej 2015-11-12 09:57:57 EST
Description of problem:
Possibility for sw RAID1 to be configured automatically as an option through Openstack Director deploy on the overcloud nodes supplied with 2 identical disks

Version-Release number of selected component (if applicable):


How reproducible:
feature request

Steps to Reproduce:
1.
2.
3.

Actual results:
no sw raid

Expected results:
sw raid1 configured

Additional info:
Comment 3 Lucas Alvares Gomes 2016-03-14 11:59:02 EDT
Targeting this at least to 9.0 since 8.0 is based on liberty and Hardware* RAID support was introduced in Ironic Mitaka.

Hardware* because we still do not support software RAID upstream, but I believe we could extend the same RAID interface to support both: hardware and software RAIDs.
Comment 4 Dmitry Tantsur 2016-11-10 06:48:45 EST
Rolling into a generic RFE

*** This bug has been marked as a duplicate of bug 1317918 ***

Note You need to log in before you can comment on or make changes to this bug.