Bug 1281464 - xfce-polkit doesn't show name in xfce4-session
xfce-polkit doesn't show name in xfce4-session
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce-polkit (Show other bugs)
rawhide
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://github.com/ncopa/xfce-polkit/...
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 10:12 EST by Ali Akcaagac
Modified: 2016-01-04 18:26 EST (History)
4 users (show)

See Also:
Fixed In Version: xfce-polkit-0.2-4.fc23 xfce-polkit-0.2-4.fc22 xfce-polkit-0.2-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:54:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample screenshot (59.67 KB, image/png)
2015-11-12 10:12 EST, Ali Akcaagac
no flags Details
fixed underscore issues (61.93 KB, image/png)
2015-11-12 10:47 EST, Ali Akcaagac
no flags Details
fixes issue with comment and name section (397 bytes, patch)
2015-11-12 11:03 EST, Ali Akcaagac
no flags Details | Diff

  None (edit)
Description Ali Akcaagac 2015-11-12 10:12:35 EST
Created attachment 1093349 [details]
sample screenshot

Please have a look at the screenshot to understand the problem :)

By the way: This package is run under Fedora 22 build from SRPM and polkit-gnome removed.
Comment 1 Raphael Groner 2015-11-12 10:29:09 EST
Hi Ali,
thanks for your bug report.

Unfortunately, xfce-polkit is currently enabled by default in rawhide (F24) only. We decided to not touch the working process of xfce4-session to provide its own desktop file for polkit-gnome in F23, see also bug #1266689.

You would have to tweak xfce4-session manually to get xfce-polkit built manually from rawhide.

I don't know if this bug is therefore invalid, at least you reported against rawhide.
Comment 2 Ali Akcaagac 2015-11-12 10:37:23 EST
To be more precise.

xfce4-session *is* build against xfce-polkit and using it.

The problem is (and that's the report) the (null) output inside the xfce4-session's information tab. I would have expected a bit more descriptive information there. So I assume, that if (null) is being shown under Fedora 22 then it most likely will show (null) under Fedora RH as well. May I ask if you could have a look in your xfce4-sessions and report if it shows (null) for you as well ?
Comment 3 Ali Akcaagac 2015-11-12 10:47:26 EST
I found the problem:

The desktop file that comes bundled with your source has two underscores applied

_Comment=....
_Name=....

I had to remove the underscores to show descriptive information inside xfce4-session-settings.
Comment 4 Ali Akcaagac 2015-11-12 10:47 EST
Created attachment 1093370 [details]
fixed underscore issues
Comment 5 Ali Akcaagac 2015-11-12 11:03 EST
Created attachment 1093374 [details]
fixes issue with comment and name section
Comment 6 Raphael Groner 2015-11-12 11:22:38 EST
I'm a little bit confused now. Does the descriptive name show when you install a new system from the Fedora 23 Xfce live iso image and any rawhide nightlies? Again, please be aware that there's no official(!) support in xfce4-session for Fedora 22 and 23.

If you think the underscores are wrong, please try to send your patch proposal to upstream. We don't touch the desktop file of upstream.
Comment 7 Rex Dieter 2015-11-12 11:42:48 EST
The patch in comment #5 is the obvious and correct fix here, you should apply it, imho.
Comment 8 Rex Dieter 2015-11-12 11:44:24 EST
(and poke upstream too of course, but that advice was already given)
Comment 9 Raphael Groner 2015-11-12 11:53:39 EST
Forwarded to upstream. Let's wait what upstream says.
Comment 10 Fedora Update System 2015-12-19 15:20:39 EST
xfce-polkit-0.2-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-399d916b80
Comment 11 Fedora Update System 2015-12-19 15:20:45 EST
xfce-polkit-0.2-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-baa83399a4
Comment 12 Fedora Update System 2015-12-20 06:25:02 EST
xfce-polkit-0.2-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update xfce-polkit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-399d916b80
Comment 13 Fedora Update System 2015-12-20 06:56:02 EST
xfce-polkit-0.2-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfce-polkit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-baa83399a4
Comment 14 Fedora Update System 2015-12-20 07:24:14 EST
xfce-polkit-0.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfce-polkit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-72d9f301e3
Comment 15 Ali Akcaagac 2015-12-21 06:50:52 EST
Sorry to burst some bubbles here. But the so called "xfce-polkit-0.2-4" update is in no way related to this bugreport.

The updated version changes back to use gnome-polkit (whatever). But this has nothing to do with the Comment and Exec parts of the *.desktop file issue - which has been fixed in upstream.

I also don't see - or don't understand - why xfce-polkit got that gnome-polkit change (which got recently removed from xfce4-session as build dependency).

Maybe someone can clarify this ? I would be willing to read about an open discussion on the fedora xfce4 mailing lists. Unfortunately some clown has changed mailman. Now daily created archives are missing (december) is missing entirely...
Comment 16 Ali Akcaagac 2015-12-21 06:55:24 EST
An appropriate xfce-polkit-0.2.4 would have looked that way:

1) revert back to xfce-polkit-0.2-3 state within Fedora git.
2) create a downstream patch from the upstream *.desktop patch (or take #5)
3) create a patch1: section within the *.spec file
4) and have 3) apply the patch from #5
5) rpmbuild the src rpm

Everything else is not related to this specific and particular bugreport. Even if you limit (through fc version check) things in the spec file. The bug (this bug) still remains until it gets fixed properly. Sending out some randomly created rpm files and relating some unrelated changes to this bugreport, doesn't solve the issues.

Just my 0.05€
Comment 17 Raphael Groner 2015-12-21 08:21:54 EST
Notes about this update:

    show name in session settings, #1281464
    version 0.2
    enable autostart for Fedora 24+ only


%changelog
* Sat Dec 19 2015 Raphael Groner <projects.rg@smart.ms> - 0.2-4
- disable desktop file in Fedora 23 and prior (in favor of gnome-polkit)

* Sat Dec 19 2015 Raphael Groner <projects.rg@smart.ms> - 0.2-3
- show name in xfce4-session, rhbz#1281464

* Sun Nov 08 2015 Kevin Fenzi <kevin@scrye.com> - 0.2-2
- Enable desktop file.

* Sat Sep 26 2015 Raphael Groner <projects.rg@smart.ms> - 0.2-1
- new version 0.2, rhbz#1266689
- disable default autostart for now to avoid conflict with xfce4-session



→ Please read what I write there in the bodhi update(s).
Comment 18 Raphael Groner 2015-12-21 08:31:50 EST
Please also notice that 0.2-2 was built in Rawhide only:

xfce-polkit-0.2-2.fc24 	kevin 	2015-11-08 17:48:10
Comment 19 Ali Akcaagac 2015-12-21 09:13:02 EST
But then the xfce4-session spec file needs to have a fc version check as well. At least that's what I believe.

Reason:

xfce4-session spec had a mandatory dependency requirement to build against gnome-polkit. This has been removed in the fedora git spec file.

Now let's pretend, that a new xfce4-session will be re-build for all releases below rawhide again (say Fedora 22), due to some changes, patches or whatever.

Then this requires (at least I believe so) a mandatory dependency to ensure that polkit-gnome is re-installed.

Currently the situation looks as follows:

I can checkout and mock (or rpmbuild) the xfce-polkit. The result can be installed even under Fedora 22.

I can checkout and mock (or rpmbuild) the xfce4-session. The result can be installed even under Fedora 22.

Now with the current situation, none of these two packages has a mandatory requirement of polkit-gnome. Therefore I can instruct yum / dnf to remove polkit-gnome because none of these two packages depend on it.

Sadly this causes a fatal issue once it comes to authentification.

So the best thing would be to add a mandatory (force requirement of the polkit-gnome) package within xfce4-session.

With other words:

Fedora below rawhide should depend on xfce4-session and polkit-gnome. xfce-polkit is only necessary from rawhide on (and most likely shouldn't be installed  below rawhide at all). So we need to ensure that everything below rawhide (that's why the version check is for) should mandatory require gnome-polkit installed.
Comment 20 Ali Akcaagac 2015-12-21 09:14:06 EST
I hope I was halfway able to explain what I like to express.

xfce4-session had a mandatory gnome-polkit requirement iirc, which got removed because of the switch to xfce-polkit.
Comment 21 Ali Akcaagac 2015-12-21 09:16:47 EST
... and ...

Regardless of my explaination above. The initial bug report was about missing session entries because of a buggy xfce-polkit.desktop file. Now by creating your new rpm files, you still have the issue remaining within rawhide.

With other words: The bug still exists and won't go away if it's not fixed properly. So no matter how things are turned.
Comment 22 Raphael Groner 2015-12-21 10:48:54 EST
Ali, I still do not get your point, sorry. I've tried to fix your issue in all branches incl. EPEL7 with applying the patch from upstream that Rex has filed. 

If you think there's still an issue, please give karma in bodhi and stop whining here, that would help more to everyone.

Maybe you should consider to report a separate new bug about the issue with polkit-gnome.
Comment 23 Raphael Groner 2015-12-21 11:00:02 EST
About xfce4-session:

Changelog
* Sun Nov 08 2015 Kevin Fenzi <kevin@scrye.com> - 4.12.1-7
- Drop patch for gnome-polkit so we can switch to xfce-polkit

xfce4-session-4.12.1-7 was built in rawhide (f24) only, just as both xfce-polkit-0.2-2.fc24 and xfce-polkit-0.2-3.fc24, see below for more details.
Comment 24 Ali Akcaagac 2015-12-21 11:10:17 EST
(In reply to Raphael Groner from comment #22)
> Ali, I still do not get your point, sorry. I've tried to fix your issue in
> all branches incl. EPEL7 with applying the patch from upstream that Rex has
> filed.

I have to apologize here. I keep following the commits here:

http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/log/

And expected a separate patch file to show up here:

http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/tree/

I now went back and looked at earlier commits and saw that you made a patch0 reference to an external URL. I wasn't aware that you can provide external urls as patch reference within a spec file. This was new to me (and now opens a few interesting ideas).

Yes! Please forget what I wrote. The package is indeed correct. My mistake!
Comment 25 Raphael Groner 2015-12-21 12:44:19 EST
http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/commit/?id=2950f4c8d4849f078331d19a203eb39a45d00e06

add build conditional for inclusion of desktop file for autostart

Now you can build your own package with optional inclusion of the desktop file. Therefore use:

$ rpmbuild -bb --with autostart xfce-polkit.spec
Comment 26 Ali Akcaagac 2015-12-22 11:05:17 EST
Thank you for the enchancements of the spec file. Unfortunately your external patch0: reference (that one that caused my initial irritation -> resulting to the longer response) causes problems with rpmspec --query.

If you download the xfce-polkit.spec file from git and run:

rpmspec --query xfce-polkit.spec

ontop of it, then it complains with this error:

error: File /root/rpmbuild/SOURCES/fabc2f7756cfb1a9cccfcc675d0857b3d3e98f84.patch: No such file or directory

If you download e.g. exo.spec file from git and run the same command ontop of it then it ends up not complaining at all ... even if it has a patch0: section inside it. The difference is: the one from xfce-polkit wants a patch with a http:// identifier while the other only wants a local file.

I don't know how you process building your rpm packages. But we heavily rely on rpm-build and use of rpmspec --query to get the to be build packages and NEVRAs.
Comment 27 Ali Akcaagac 2015-12-22 12:14:41 EST
Ok after some investigations this seem to be correct as well. At least valid, from rpm.org. I therefore filled a bug to rpmspec people.

https://bugzilla.redhat.com/show_bug.cgi?id=1293687

Getting from Alpha to Omega here (for just a plain 2 liner).

:(
Comment 28 Kevin Fenzi 2015-12-22 14:45:24 EST
This is not a bug anywhere. 

Patches are stored in git next to the spec files: 

http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/tree/?id=2950f4c8d4849f078331d19a203eb39a45d00e06

rpmbuild doesn't download things, the urls in patch/sources are for users reference or use with other tools like spectool.
Comment 29 Ali Akcaagac 2015-12-22 15:32:40 EST
(In reply to Kevin Fenzi from comment #28)
> This is not a bug anywhere. 

Yes I am aware of that. Unfortunately rpmspec reported an error because it can't handle the URI reference in the patches macros of a spec file. It behaves differently (or better: it reports an error) to URI referenced patches than file referenced ones. That's why I opened the bug as under #27.

rpmspec --query some.spec

will return:
1) error, if a patch macro has http://someurl.com/somepatch.diff
2) nothing, if a patch macro has somepatch.diff
embedded.

Our build farm threw that error because it ran above rpmspec on the xfce-polkit.spec file and aborted.

> rpmbuild doesn't download things

I am aware of that too. Our build farm grep's all source and patch macros and download the files from the correct places.
Comment 30 Raphael Groner 2015-12-22 16:48:05 EST
For a previous build (0.2-3), I did fedpkg upload patch, maybe that's the confusing point here cause it so stores the patch instead (of just directly uploading it) into git lookaside cache with a checksum in sources file ¹. You can alernatively download all sources from individual commits of cgit as a tarball ².
¹ http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/commit/sources?id=9c978f35e5b7e293338098880fa542e068750c69
² http://pkgs.fedoraproject.org/cgit/xfce-polkit.git/snapshot/xfce-polkit-2950f4c8d4849f078331d19a203eb39a45d00e06.tar.xz
Comment 31 Ali Akcaagac 2015-12-22 17:34:39 EST
Thanks! Everything works as expected and as usual again. Only had to modify our build farm (and the scripts around it) to allow build conditions and to deal with that one particular rpmspec --query error complaint.
Comment 32 Fedora Update System 2015-12-28 17:54:54 EST
xfce-polkit-0.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2015-12-28 18:51:54 EST
xfce-polkit-0.2-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 34 Fedora Update System 2016-01-04 18:26:03 EST
xfce-polkit-0.2-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.