Bug 128148 - system-config-display --reconfig --noui fails
system-config-display --reconfig --noui fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 08:09 EDT by Michael Young
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 10:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2004-07-19 08:09:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6)
Gecko/20040116

Description of problem:
When I run the command
system-config-display --reconfig --noui
I get the error
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

The problem seems to be the lines 336-7
    if reconfig and loop_count == 0:
        continue
in /usr/share/system-config-display/xconf.py
which discards the first card in the card list. Since the system in
question only finds one card the configuration fails. If I comment out
these lines, the command works as expected.
Package versions are system-config-display-1.0.14-1 and rhpl-0.143-1
Comment 1 Michael Young 2004-07-20 10:44:16 EDT
Actually, it seems this bug is already fixed in the rawhide version.
Comment 2 Sindre Pedersen Bjørdal 2004-08-30 16:13:25 EDT
I really do think there should be an update for this for the current
release (Core 2). If users get stuck without X and this doesn't work
they're kind of lost. This is a severe bug IMHO. 
Comment 3 Barry K. Nathan 2004-09-02 00:21:27 EDT
I was just bitten by on a production system. :(


Here's a possible workaround though:

mkdir /root/old-x-files
mv /etc/X11/xorg.conf* /etc/X11/XF86Config* /root/old-x-files
system-config-display

rather than
system-config-display --reconfig

Note You need to log in before you can comment on or make changes to this bug.