Bug 1281519 - [Docs]: RHOSP node network restrictions
[Docs]: RHOSP node network restrictions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: TP3
: 1.0
Assigned To: Julie
Landon LaSmith
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 11:20 EST by Thom Carlin
Modified: 2016-05-03 01:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 01:09:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-11-12 11:20:20 EST
Description of problem:

If the RHEL-OSP node is not setup correctly, the result may not clearly indicate the root cause.  We should add setup information to help the customers since this may be an involved process for them.

Version-Release number of selected component (if applicable):

TP2

How reproducible:

100%

Steps to Reproduce:
1. Misconfigure node
2. Register Nodes in Sat 6 (Deployment > OpenStack)
3.

Actual results:

Register node hangs at 90%, then errors with "Error, cannot convert nil to String"

Expected results:

Better error messages

Additional info:

Restrictions identified so far:
* Client (node) Boot device must be only PXE (no local drives)
* Client (node) PXE NIC  must be the one connected to the RHEL-OSP (provisioning) network
* PXE client (node) must be able to contact PXE server on RHEL-OSP network (proper VLAN)
* PXE server must be functioning
Comment 1 Thom Carlin 2015-11-12 12:58:51 EST
Also note it may take an hour for Ironic to timeout in these cases
Comment 3 Thom Carlin 2016-04-04 21:25:35 EDT
"Client (node) Boot device must be only PXE (no local drives)" was incorrect.  Should be: "Client (node) Boot device must have PXE at a higher priority than local drives"

Asking jmontleo for review also
Comment 9 Landon LaSmith 2016-04-19 08:58:56 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.