Bug 1281522 - acl - regression - trailing ', (comma)' in macro matched value is not removed.
acl - regression - trailing ', (comma)' in macro matched value is not removed.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: Regression, ZStream
Depends On: 1280123
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 11:27 EST by Jan Kurik
Modified: 2015-12-08 05:34 EST (History)
7 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.4.0-20.el7_2
Doc Type: Bug Fix
Doc Text:
Previously, in access control evaluation, retrieving a matched value for a macro failed to remove a trailing comma. As a consequence, if the Access Control List (ACL) contained a macro, the correct permission was not provided. To fix this bug, if a trailing comma is found in the matched value, the comma is properly removed. As a result, if the ACL contains a macro, the correct permission is provided.
Story Points: ---
Clone Of: 1280123
Environment:
Last Closed: 2015-12-08 05:34:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-12 11:27:40 EST
This bug has been copied from bug #1280123 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 8 Amita Sharma 2015-11-27 10:59:24 EST
Thanks Noriko,

Build Tested ::
================
[root@dhcp201-167 export]# rpm -qa | grep 389
389-ds-base-1.3.4.0-21.el7_2.x86_64
389-ds-base-debuginfo-1.3.4.0-21.el7_2.x86_64
389-ds-base-libs-1.3.4.0-21.el7_2.x86_64


quickinstall startup 	100% (5/5) 	  	 
Acl startup(o=ace industry,c=us) 	100% (1/1) 	  	 
Acl run(o=ace industry,c=us) 	  	0% (1/400) 	 
Acl cleanup 	100% (1/1) 	  	 

One failure is not related to this bug, that is script issue.
Comment 10 errata-xmlrpc 2015-12-08 05:34:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2572.html

Note You need to log in before you can comment on or make changes to this bug.