Bug 1281541 - SELinux is preventing appsrc0:src from 'create' accesses on the file orcexec.T8swm6.
SELinux is preventing appsrc0:src from 'create' accesses on the file orcexec....
Status: CLOSED DUPLICATE of bug 1164473
Product: Fedora
Classification: Fedora
Component: orc (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
Fedora Extras Quality Assurance
abrt_hash:bccb9e92dfa1d46245b68e20f9d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 12:41 EST by kior
Modified: 2015-11-23 03:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 03:29:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kior 2015-11-12 12:41:48 EST
Description of problem:
SELinux is preventing appsrc0:src from 'create' accesses on the file orcexec.T8swm6.

*****  Plugin catchall (100. confidence) suggests   **************************

If вы считаете, что appsrc0:src следует разрешить доступ create к orcexec.T8swm6 file по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
чтобы разрешить доступ, выполните:
# grep appsrc0:src /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                orcexec.T8swm6 [ file ]
Source                        appsrc0:src
Source Path                   appsrc0:src
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   8
First Seen                    2015-11-12 20:33:04 MSK
Last Seen                     2015-11-12 20:33:18 MSK
Local ID                      a51acf93-eabe-41ed-bb6f-b68a203ac64f

Raw Audit Messages
type=AVC msg=audit(1447349598.432:623): avc:  denied  { create } for  pid=3437 comm="appsrc0:src" name="orcexec.T8swm6" scontext=unconfined_u:unconfined_r:thumb_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file permissive=0


Hash: appsrc0:src,thumb_t,user_home_dir_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1164473
Comment 1 Miroslav Grepl 2015-11-20 06:47:45 EST
See #1164473.
Comment 2 Fabian Deutsch 2015-11-23 03:29:10 EST

*** This bug has been marked as a duplicate of bug 1164473 ***

Note You need to log in before you can comment on or make changes to this bug.