Bug 1281553 - BIOS PXE Boot Directions in Install Guide Incorrect
BIOS PXE Boot Directions in Install Guide Incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
7.1
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Clayton Spicer
ecs-bugs
: Documentation
: 1289596 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 13:50 EST by rmarshall
Modified: 2016-01-20 08:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 08:02:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rmarshall 2015-11-12 13:50:38 EST
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7-Beta/html/Installation_Guide/chap-installation-server-setup.html#sect-network-boot-setup-bios

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/chap-installation-server-setup.html#sect-network-boot-setup-bios

Section Number and Name: 
IV. 21.1.1

Describe the issue: Configuration locations incorrect, conflicting systemctl instructions, and unclear directions for obtaining boot files. This is true for both RHEL 7 and 7.2 Beta as noted in the document links above.

Suggestions for improvement: 

Step 5 states:

"You now need the pxelinux.0 file from teh SYSLINUX package in the ISO image file. To access it, run the commands as root:"

It should specify the full DVD install ISO as the instructions are not correct for the netboot ISO.

Step 7 states:
"Add a configuration file named default to the pxelinux/ directory.
A sample configuration file at /var/lib/tftpboot/pxelinux/default might look like:"

This configuration fails, the file should be at location:

/var/lib/tftpboot/pxelinux/pxelinux.cfg/default

Step 9 should only require the user to enable and start xinetd.service and dhcpd.service. Systemd is aware that xinetd will start the tftp service on demand and attempting to start/enable it errors out leading the user to believe the system is not functioning properly.
Comment 2 Clayton Spicer 2015-12-09 07:39:39 EST
*** Bug 1289596 has been marked as a duplicate of this bug. ***
Comment 5 Petr Bokoc 2015-12-17 10:01:39 EST
Looks good to me.

Note You need to log in before you can comment on or make changes to this bug.