Bug 1281567 - [RFE] [Neutron] VLAN aware VMs
Summary: [RFE] [Neutron] VLAN aware VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jakub Libosvar
QA Contact: Alexander Stafeyev
URL: https://blueprints.launchpad.net/neut...
Whiteboard: upstream_milestone_newton-rc1 upstrea...
: 1329384 1371441 (view as bug list)
Depends On: 1371842 1371847
Blocks: 1281573 1396164 1335593
TreeView+ depends on / blocked
 
Reported: 2015-11-12 19:59 UTC by Stephen Gordon
Modified: 2017-12-25 09:58 UTC (History)
19 users (show)

Fixed In Version: openstack-neutron-9.0.0-0.20160929051647.71f2d2b.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:17:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
Github openstack/neutron-tempest-plugin/blob/master/neutron_tempest_plugin/scenario/test_trunk.py None None None 2017-12-25 09:58:42 UTC
OpenStack gerrit 92541 None None None Never
OpenStack gerrit 94612 None None None Never
OpenStack gerrit 106744 None None None Never
OpenStack gerrit 106747 None None None Never
OpenStack gerrit 210309 None None None Never
OpenStack gerrit 210310 None None None Never
OpenStack gerrit 210311 None None None Never
OpenStack gerrit 210312 None None None Never
OpenStack gerrit 210313 None None None Never
OpenStack gerrit 212549 None None None Never
OpenStack gerrit 243786 None None None Never
Launchpad 1623708 None None None 2016-10-03 12:40:37 UTC
Launchpad 1636484 None None None 2016-10-25 12:54:22 UTC
Launchpad 1636485 None None None 2016-10-25 12:55:06 UTC

Description Stephen Gordon 2015-11-12 19:59:00 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms.

Description:

This blueprint proposes how to incorporate VLAN aware VM:s into OpenStack. In this document a VLAN aware VM is a VM that sends and receives VLAN tagged frames over its vNIC.


Specification URL (additional information):

https://review.openstack.org/#/c/94612/

Comment 2 Assaf Muller 2016-05-03 12:32:48 UTC
*** Bug 1329384 has been marked as a duplicate of this bug. ***

Comment 3 Nir Yechiel 2016-08-30 15:00:55 UTC
*** Bug 1371441 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Libosvar 2016-10-03 12:40:38 UTC
Waiting for rc2 rebase that includes fixes for https://bugs.launchpad.net/neutron/+bug/1623708 that implements agent restart resiliency.

Comment 9 Nir Yechiel 2016-10-06 16:15:26 UTC
Marking as Tech Preview for RHOSP 10.

Comment 15 Alexander Stafeyev 2016-11-14 17:33:23 UTC
Basic VLAN aware VM test passed. 
It includes the following: 
Creation of networks, ports, trunks and subports. Booting VMs with trunk port id. Configuring Vlan on VMs and sending traffic between VMs on with same and different VLANS. Deletion of the VMs, trunk and subports.

Comment 18 errata-xmlrpc 2016-12-14 15:17:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.